Stuck on the "Updates and Other Software Screen"

I have an iMac 12, 2, and I’m trying to install ZORIN OS Education on it. However, on the Updates and Other Software Screen, when I click “Continue”, it freezes, and an error message pops up with the text “??? ???”.

I recently erased my Macintosh drive as Mac OS Extended (Journaled). Can anyone help me? Many thanks!

Can you run through terminal

sudo apt autoremove && sudo apt autoclean -y

and then

sudo apt update && sudo apt upgrade -y

When you run ‘sudo apt update’ - watch the printout for any unsigned keys or 404 errors.
If there are any, remove those repositories, then log out and in and test the app Software & Updates.

Hi,

When I run sudo apt update && sudo apt upgrade -y, after a while, it says that I’m out of storage? The USB drive is 32GB and it is partioned into three sections - two smaller ones and 27 GB of empty space. How do I increase the space to allow the second command to run? Thanks

Ah… I see. Are you running Zorin as “Try Zorin” or with Persistence from the USB?
That is, it is not installed on the computers drive?

Zorin OS is not installed yet; it’s running as “Try Zorin” from the USB.

Zorin as well as Linux does not operate in quite the same way as Windows. Windows needs to be defragged- Linux does not.
The reason for this:
Windows allocates write space based on the next available block or sector. Linux allocates write space based on the ‘size of the program and files, plus upgrade and update room’. This prevents fragmentation. If the program and files in question outgrow that space, then the entire thing is kept together and moved to a new and larger position.
But this also means that the system allocates larger spaces than Windows does. My own opinion is that the advantages vastly outweigh that disadvantage.
If a person uses “Try Zorin” (or on other distros, the equivalent) on a medium that does nto have enough available blocks or sectors for write, then it can cause updater to not work, since the space is too limited.
I would think a 32 gig USB stick would be enough for a basic trial and exploration, but if the USB stick already has other data written on it (Creating the bootable medium may not delete unrelated files; my own Try or Test stick has my back ups on it, too) or the “try Zorin” instance has been used to add other software and programs, it may have gotten too crowded. My other “Try and Test” stick is 64gigs.

1 Like

Ah, so I should reformat the USB to it’s default settings; reflash the image; run the commands in the terminal, and then attempt installation?

Thanks for your help :slight_smile:

If you feel you are ready to install, then by all means.
You will not need to run the above commands in terminal, however. Those were supplied assuming that Zorin was installed with plenty of space and that something had snagged in APT causing the Updater to halt.

Hi there,

I attempted installation with both ZORIN OS Education and ZORIN OS Education Lite, and the error message “??? ???” pops up at the updates and installation screen. However, the strange thing is, after running the commands you sent over a few messages ago, the installer has many error messages (at each page), but it is able to go to the next page, where I choose the timezone. It freezes at that point.

May I ask if you have any suggestions?

Thanks so much

In Software & Updates, on the first tab (The one it opens to)
Are you set to ‘Download from:’ “Main Server”?

Can you check your Locale and Language settings?

I haven’t gotten ZORIN OS successfully installed yet; I’m installing it through “Try Zorin OS”, so I can’t see that

Is the Machine 32 bit and the copy of Zorin OS 64bit?

The machine and copy are both 64 bit :grinning:

I vaguely recall the Software & Updates giving an error of only Question Marks being mentioned one time- on the old Zorin Group Forum. Someone posted a very simple solution, I think. But I cannot remember the details. It’s been a while. Searching for it has gotten me nowhere.

Ok, I’ll look for that!

Which pages and can you relay any or all of those errors?
Can you give details on the Computer system; processor, video card how much RAM?

EDIT: I missed seeing something important in the OP. I do not know how I missed it, but I did.
iMac 12.

https://help.ubuntu.com/community/Intel_iMac

Sure, I’ll try rerunning the commands and take pics of the installer errors. When I run the commands, it says there is not enough space though, because I’m only able to try ZORIN OS

The iMac has:
Processor: 2.7 GHz i5
Ram: 4 GB 1333 MHz DDR3
Graphics / Video Card: AMD Radeon HD 6770M 512 MB
More detailed info about my iMac here: iMac 27-Inch "Core i5" 2.7 (Mid-2011) Specs (Mid-2011, MC813LL/A, iMac12,2, A1312, 2429): EveryMac.com
Thanks for your help! Sorry for the late reply by the way.

Update: Forgot to mention that I erased the Macintosh drive with MacOS and reformatted it as MacOS Extended (Journaled). Also, part of the drive is partioned with Windows installed.

There is no need to- as at the time I posted that, I thought you were running a fully installed system.
For installing on an iMac, you may need a few extra or different steps;
https://help.ubuntu.com/community/Intel_iMac