Sudo apt not working

Hi all, I'm trying to Dino XMPP. I tried to use the sudo apt command and it gave me an error. Then I downloaded the deb package and when I ran it, my software app kept spinning and spinning. Then I followed another topic's advice to use sudo apt update, and it gave me an error. I also tried using the sudo apt to reinstall gnome, error.

I then I read that I could use gdebi to help make downloading deb packages easier, so searched for it in my software app and it's not there. So I ran the command suggested sudo apt install gdebi, and I get an error.

Also, I have a red exclamation mark at the top right of my computer after restarting and it says an error occurred and to run Package Manager or terminal apt-get - but no further instructions.

Any help, sorry, been new to Linux for a month and it is a massive learning curve. I feel like I can spend 4 hours granting access to a new USB or installing a new file sometimes.

Is secure boot turned off in the bios ?

How do I check?

Please post a screenshot or type out the exact Error.
This error must be resolved before you can install anything.

One example when I tried to install the Dino:
E: Type 'gpg' is not known on line 3 in source list /etc/apt/sources.list.d/network:messaging:xmpp:dino.list
E: The list of sources could not be read.
E: Type 'gpg' is not known on line 3 in source list /etc/apt/sources.list.d/network:messaging:xmpp:dino.list
E: The list of sources could not be read.

Now the Dino icon is in my apps, but when I click to open, the Software app opens and just spins

Please open Software & Updates and move to the "Other Software" tab.
Scroll through the list and select any DINO repositories by clicking on the line it is on, then clicking the Remove button on the bottom toolbar.
Once you are sure that there are no DINO repositories remaining, close out Software & Updates

In terminal, run

sudo apt --fix-broken install

(If Dino is showing in your apps, you may need to remove it, first:

sudo apt remove --purge dino

Once that is complete;
Download this Self-Installing .deb package:

Double click the package to run the installer.
This should get you all fixed up and have Dino installed.

I don't see anything that has Dino in the Other Software tab in Software & Updates, I opened my terminal and ran the sudo apt --fix-broken install and this is what I got:

E: Type 'gpg' is not known on line 3 in source list /etc/apt/sources.list.d/network:messaging:xmpp:dino.list
E: The list of sources could not be read.
E: Type 'gpg' is not known on line 3 in source list /etc/apt/sources.list.d/network:messaging:xmpp:dino.list
E: The list of sources could not be read.

Open Software & Updates and move to the "Other Software" tab.
Look for network:messaging:xmpp:dino.list
I Promise it is there because it is showing up as /etc/apt/sources.list.d/network:messaging:xmpp:dino.list

You may need to Scroll Down to see it.

The screen shot shows everything, is it the unsupported updates? stable ??? Should that one be there @Aravisian

Are you certain that you cannot scroll down, any?

In the meantime, you may need to use the File manager to do it. You must elevate to ROOT to do so.

sudo -i


navigate to /etc/apt/sources.list.d/
Look for xmpp:dino.list
Right click the file and delete or send to trash.

No, that is not related to this issue.

That is up to the O.P. I do not believe that is the DINO repository...
Logbook of the World?


Okay, I found the file and deleted it. I then ran the commands you gave me and they both worked.

I think downloaded the deb package you gave me and when I go to run it, my Software opens up and spins and spins

Hey Michel, it should be, I run a full node for Qortal on my computer

You probably need to update the sources list first, since you deleted that file:

sudo apt update


sudo apt install gdebi

It will take a bit of time... use Gdebi to install the .deb package you downloaded.


I need to send you a Christmas gift, I cannot thank you enough


Is a deb package like a zip, now that I've installed it, can I delete it?

Yes, you can if you want to. Or you can keep it to use to remove the package in the future.

Thank you for EVERYTHING