Sudo apt upgrade

When i run sudo apt upgrade on my Zorin machine i got this irritating message?

Get more security updates through Ubuntu Pro with 'esm-apps' enabled:
rpm2cpio libmaven3-core-java libgegl-0.4-0 ant python2.7-minimal
libmagickwand-6.q16-6 libgegl-common python2.7 librpmio8 rpm-common librpm8
libhttpclient-java libopenexr24 libsdl2-2.0-0 libsdl2-2.0-0
libmagickcore-6.q16-6 libpython2.7-minimal libpython2.7-stdlib ant-optional

What does it mean should i be worried?

This is far from normal. Zorin blocks normally those Ubuntu ESM-programs out of their systems. The message you see and get is from Ubuntu Pro extended update program (another extra 5 years full support, on top of the 5 years normal support of the LTS-program).
See your resources list what you have dragged inside Zorin that should not be there.
But, of course, this is a message you can ignore. But as said, you are inside the Ubuntu Pro setup, and for using it you need a SingleSignOn-account AND a Token from Canonical to be a beneficiary of Ubuntu's 10 year full support.
But I doubt really that Zorin 16 can be a part of such a program.

I have 4 Ubuntu Pro's, therefor I really know. lol ... my Zorin is a full upgrade hyper-modern system running on kernel 6.2 and Linux-firmware 20230219xxx , but I have NO SUCH messages at all.
Maybe you ought to try to get 10 years support on Zorin now lol ..... maybe it can work.

1 Like

No, it's just Ubuntu trying to push their Pro subscription...

The product itself is not bad as it aims to extend the support for another 5 years, totaling to 10 years of support without having to re-install to a newer LTS version.

However, pushing it like this it's just the wrong play here as it confuses people without reason. It also doesn't make a lot of sense to most desktop/laptop users but rather servers where stability is much more important concern.

No such thing they do that on Zorin

This is an Ubuntu thing, so clearly somehow ZorinOS is pulling this information from somewhere without realizing it.

Better go checking what our dearest friend, the Topic Starter, dragged into his system from Ubuntu instead of using Zorin's repo's.
When I run on a Clean original Repo System I get this on a sudo apt upgrade

Schermafdruk van 2023-02-25 11-05-37

As said .... I drag in repo's a lot of times for all reasons to be on top level with the latest kernel out there .... But I delete, of course, such repo's out again before you get one hell of a nasty mix up ......
But I already understand that beginners make those typical mistakes ..... And some blogs do not care for correct information they share.

This is a valid question for @Jonte, did you add any repositories to your system? Maybe you followed some guide online or something?

Not recenly but i did a mistake to upgrade to Ubuntu LTS 22.04 and i think that has effected my machine?

I can post my source.list here before!

Before i ran Zorin OS i used Ubuntu on this machine?

Here is my sources.list
Updates and upgrading works normally today i recieved Zorin OS Default settings and Zorin Print?

deb cdrom:[Zorin-OS 16 Core 64bit]/ focal main restricted

See UpgradeNotes - Community Help Wiki for how to upgrade to

newer versions of the distribution.

deb Index of /ubuntu focal main restricted

deb-src Index of /ubuntu focal main restricted

Major bug fix updates produced after the final release of the


deb Index of /ubuntu focal-updates main restricted

deb-src Index of /ubuntu focal-updates main restricted

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team. Also, please note that software in universe WILL NOT receive any

review or updates from the Ubuntu security team.

deb Index of /ubuntu focal universe

deb-src Index of /ubuntu focal universe

deb Index of /ubuntu focal-updates universe

deb-src Index of /ubuntu focal-updates universe

N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

team, and may not be under a free licence. Please satisfy yourself as to

your rights to use the software. Also, please note that software in

multiverse WILL NOT receive any review or updates from the Ubuntu

security team.

deb Index of /ubuntu focal multiverse

deb-src Index of /ubuntu focal multiverse

deb Index of /ubuntu focal-updates multiverse

deb-src Index of /ubuntu focal-updates multiverse

N.B. software from this repository may not have been tested as

extensively as that contained in the main release, although it includes

newer versions of some applications which may provide useful features.

Also, please note that software in backports WILL NOT receive any review

or updates from the Ubuntu security team.

deb Index of /ubuntu focal-backports main restricted universe multiverse

deb-src Index of /ubuntu focal-backports main restricted universe multiverse

Uncomment the following two lines to add software from Canonical's

'partner' repository.

This software is not part of Ubuntu, but is offered by Canonical and the

respective vendors as a service to Ubuntu users.

deb Index of /ubuntu focal partner

deb-src Index of /ubuntu focal partner

deb Index of /ubuntu focal-security main restricted

deb-src Index of /ubuntu focal-security main restricted

deb Index of /ubuntu focal-security universe

deb-src Index of /ubuntu focal-security universe

deb Index of /ubuntu focal-security multiverse

deb-src Index of /ubuntu focal-security multiverse

This system was installed using small removable media

(e.g. netinst, live or single CD). The matching "deb cdrom"

entries were disabled at the end of the installation process.

For information about how to configure apt package sources,

see the sources.list(5) manual.

Check the Software Center and in the settings, look into Repositories (I don't know the exact names so look for something related). There you should have a list of the repositories in use, and should be able to toggle them. You can try to disable anything that comes from Ubuntu, that should get rid of the warning.

Can you me a picture?

I'm not on Zorin right now but here's how it should look like:

From this thread:

10 years support have distribution Rocky Linux.

Can i ignore this message?

For Clarity, Jonte recently followed an alert to "Upgrade" to Ubuntu 22.04. In this action, he added repositories for Ubuntu.
In that thread, we replaced his sources.list.
@Jonte have you checked the contents of /etc/apt/sources.list.d?


I used the terminal to navigate to that folder and got this scrren dump below:


The git-core-ubuntu - is this something you manually added? if it is not, you should remove each of those.
Please remove all the files labeled as "dist-upgrade".
You should have:


1 Like

Which command does remove these files?

The rm command. IF you are not in the terminal opened as root, include sudo.
For example:

sudo rm zorinos-ubuntu-stable-focal.list.distUpgrade

I tried to remove these as you said?

Is this correct?