Super key is not working

Hi all,

I have a question, my super key is not working on my notebook. How can i configure that one ?

This is my keyboard from the notebook

This is how it looks in my os:

I also tried to change to a different keyboard in linux but that did not make any difference. Any ideas ?

Update: it seems to work when i enable the touchpad ... that's weird.

Here a video:

Seems alot of reports about this super key.

1 Like

What make and model is the notebook? Remember hardware with a Windows key present will mean it was built with Drivers for Windows, unlike a penguin keyboard. :wink:

Another strange issue that I have never encountered on a machine before. I literally have no idea. Maybe check the keyboard shortcut section in settings, and insure that the SUPER key is set properly to open activities, or whatever you want it to do.

And SWARF, I never heard of a penguin keyboard before, a keyboard specifically made for Linux?


Hmmmm?

1 Like

Yes there was and at one point Linux Format magazine used to award them to the best letter to the editor! Can't remember if it was Cherry or another brand and it was a scientific keyboard (still QWERTY).

Here is an example:
https://www.thinkpenguin.com/gnu-linux/penguin-keyd-backlit-quiet-mechanical-rgb-keyboard-tpe-penkeybd2

1 Like

Thats a very nice keyboard, it uses Cherry Red switches, we know Cherry is quality. Its mechanical, so it got your tactile benefit. And its got your gamer RGB. I like the fact that its a full keyboard, none of that mini stuff. And I like the penguin on the super key. Maybe that renamed the TUX key.


Acer Predator G9-793

Looks like its even been a problem with Windows users too!

https://community.acer.com/en/discussion/533617/windows-button-not-working

https://community.acer.com/en/discussion/547097/windows-key-on-keyboard-not-working

3 Likes

Well its working when i enable touchpad, see my video in post 2. Its weird its related to touchpad

I see 2 posts there

Open Predator Sense... there would be an option to enable/disable windows key - irrespective of whatever state your touchpad is.

And

yes, it's sort of "gaming" mode, so you will not be kicked to desktop if you press windows key.

So if it can be enabled i really want to learn how without using the touchpad

From what I gleaned its dependent on some specific software that has the Windows key disabled by fault, so I suspect your behaviour issue will be down to the fact that that piece of software was designed only for Windows, and you are running GNU/Linux.

1 Like

They say by defaut it is disabled and with the predator app it can be enabled without the need to enable the touchpad. I wonder if it can be configured in linux as well.

How it works in linux is the same as in windows

WOW, that is amazing to me. When even a Windows user isn't safe from a debacle such as that. Good job SWARF on finding that information. Just goes to show Windows isn't the answer for everything.

And Michel, I am really sorry dude. Things should just work. But, if it does work with the trackpad enabled, then it gives me an idea. What if you were go go inside your notebook, and disconnect the trackpad at the wire? Yes, I did just give you a brilliant beyond brilliant idea, you can thank me later.

If this works, that will most certainly solve the problem. Good luck!


2 Likes

Haha thanks for thinking with me, but i am not going to open my notebook for that.

In windows there is a acer predator sense app that can enable the super key without the need to enable or disable the trackpad. So i wonder if something can be done to enable the super key in linux as well.

I dont need the super key, but i love to try and experiment a bit in linux. I will do some research later, maybe i can find something.