Super + right key did not tile window to right side

Found this bug in Zorin lite os 16.1.
After installing, Super + right key did not tile window to right side.
I went to windows manager, and changed the settings to a new key , super + x.
and it started to align the window right side.

However, after reboot, i was again not able to align the window to right side using super + x key combination.
Is there any workaround possible for this?

You need to set it manually, in the start menu search for window manager and select keyboard in it. Now search for option for tile window to the right and double click, select your shortcut. You can also do this with the other options present there. This should solve your Problem :wink:

However if Super + (Shortcut) Reset's after Reboot, It means another shortcut or process is using the same shortcut. You can use Alt + (Shortcut) to solve this Issue.

as ghostminator said , go to window manger and go to tab keyword:

but I think there r someting like bugs here: tile to right and tile to down, u need to edit it.
but i noticed that, there is mix bw keyboard arrows, and keypad arrows(look at arrows above number 2,4,6,8), and noticed also every item may be bindings to more than arrows.
to solve that, click on the item u want to edit it, and click on clear once time or twice until u get clear space,then click on edit and add the correct key using super+key u want.
for me i choice the number arrows, because it is easy to use more tiling with 1,3,7,9(look at tile to the bottom-left,tile to bottom right,tile to top-right, top-left)

I have noticed the Bugs you were mentioning and they appear to be true, I however made somewhat a better arrangement by using the keypad keys for arrangement and the alt key for activation.

Using the super key for activation also worked, But the super + 8 (keypad) is also overwritten after restart, So, I prefer the use of Alt key.

no problem, what work for u , u do, it's depend on habits and comfortable, for me i'm used to use super, but i recently use autotiling app , it's perfect, no need for keys :wink:

I have noticed a bug in Zorin OS in regards to the Super Key on multiple topics on the forum over time.
I believe this bug stems from, simply put... different applications fighting over the use of that exclusive and popular key.
The more configuration-editing applications that try to take charge of what this key does, the more likely that one config file will conflict with another.
This bug is not present on several distros using XFCE.
But it is present on distros using XFCE that also introduce their own apps and keyboard shortcuts that relate to the use of that key OR...
On distros that use XFCE but also use Gnome settings applications.


I tried to setup the shortcut keys similar to you. And it did work.
But after I logged out and logged in again, I could not tile window to the
left. Tiling window to the right worked.
Not sure if this problem is specific to mine installation and I've a clean installation btw.

I suppose you should set all of them according to their roles, like I can see their are some which are not yet set according to the one I shared and a restart is not usually needed in this case, they start working on other windows immediately. If you are already using the same shortcut for something else, they will not work.


So, for me it works only till i've not logged out.
Once i log out, and log in again, the "tile window to the left" doesn't work.
I'm pretty sure there is no other shortcut assigned to "alt + 4" other than the "tile window to left".
And if it was the case, then why does it work till I've not logged out :slight_smile: .

click on clear once time or twice or more until u get clear space,then click on edit and add the correct key using super+key u want
I'm sure it is working, if u reboot and there is item not worked, u will do that again with it, and it will work forever

You Should give @eid's suggestion a Try, I hope you will get some great result's :smile:
Use the clear button two to three times, then set the Shortcut. It may work well for you.

sometimes, there r more than key bindings to the item, if u click clear u will see one of them, of u clear again may see anthor one , if u click clear again u will get clear space(no any key bindings) then u will edit to add ur key


This one did the trick.
So when we are setting a new key binding to an item, we should clear the existing key binding first. Nice find.

I noticed also if u reboot and there is item not worked, u will do that again with it , and it will work forever, I faced that with super+8, and it's working good

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.