Superkey mapping

Hi all, I am trying to map the super key so that pressing it launches ulauncher. I have tried to do this:

And while the Super key stops working, it doesn't launch ulauncher for me. Has anyone else tried this? Thank you very much for the help.

Zorin Menu > Settings > Keyboard shortcuts > scroll to the bottom, click the '+' button, and enter:

Name: Ulauncher
Command: gnome-terminal -- /bin/sh -c 'ulauncher'
Shortcut: Super

I'm not sure what the name of ulauncher is, so you might need to change 'ulauncher' to something else.

Also, make sure the Super key isn't already mapped to open the Zorin Menu... right-click Start Bar > Zorin Appearance > Interface > Left Super Key.

You can find some really neat stuff in dconf-editor:
sudo apt install dconf-editor

Suggested search terms within Dconf Editor: Super, overlay

Hi Mr_Magoo thank you very much for taking your time to help me.

By doing this:

Zorin menu > Settings > Keyboard shortcuts > scroll to the bottom, click the '+' button and enter:

Name: Ulauncher

Command: gnome-terminal -- /bin/sh -c 'ulauncher'

Keyboard shortcut: Super

It won't let me assign a single-key shortcut, it has to be a two-key shortcut.

The strange thing is that before I had it configured like this. It's since I formatted last week. My previous version was two years ago. Possibly something changed in the Zorin Os extension.

I will keep an eye on the Dconf, thank you very much.

@merucu , had you followed this crucial step?

1 Like

Hi Aravisian, yes I have that step done as well. In that step only let me choose two actions, zorin menu and activity view (I do not know if in the English version is called the same.) And I have chosen the option that is not zorin menu.

Let's try this:

Set up the ulauncher keybinding as shown above, use Super+H or whatever key you want.

Within Dconf-Editor:

Find the keybinding that reflects what you set up for ulauncher, and edit it to remove the H (or whatever key you used), so it's just 'Super'.

Let me know if that works for you.

1 Like

Hello again Mr_Magoo, I have tried it and it does not work. I'm going to paste some screenshots just in case I'm doing something wrong.

It launches the gnome shell activity center, when I press super.

Ok, the Super key is still mapped somewhere... let me do more research, maybe we can hijack the gnome shell activity center, change it to ulauncher from within Dconf-Editor, and it'll work.

What's the actual application name for the gnome shell activity center?

This is the activity center.

What I find strange is that I look for all references to Super and Super_L, I change them, but the unique Super combination for ulauncher does not launch. Instead if I go to a launcher Super + something. Yes it launches it.

No, that can't be it... I changed Zorin Appearance to open the 'Activities Overview' when I press the Super key, and that value doesn't change... it's got to be somewhere else in Dconf Editor. That setting you show has a value of [] on my system, instead of Super + s like yours shows.

I'll keep searching... we'll find it. When we do, we'll attempt to put ulauncher instead of what's in there now.

[EDIT 1]
I'm currently searching for 'binding', then going through all the settings to see if there's anything pertinent.

[EDIT 2]
OK, that's a bust... I'm now researching how to use the bind command to bind ulauncher to the Super key.

sudo showkey shows that the Super key is keycode 125 (it might be different on your system, you'll have to check)

sudo showkey -s shows that the Super key has a scancode of 0xe0 0x5b.

So the command is going to be something like:
sudo bind -x Super_L:ulauncher
... but I'm not sure if that's exactly correct... the man page is somewhat opaque, and I don't have ulauncher installed to test it.

If you test it, and it doesn't work, you can undo it via:
sudo bind -u ulauncher

Hi Mr_Magoo thank you very much for all the help. Yes my super key corresponds to 125.

I found a solution using xcape and remapping the keyboard, but it makes my computer very slow:

xcape -e 'Super_L=Super_L|Z'

1 Like

That's it! I fixed it with xbindkeys, then I will make a tutorial, to explain how I did everything step by step. The key was the bind command. Thank you very much Mr_Magoo.

1 Like

Don't forget that there's also xbindkeys-config

sudo apt search xbindkeys
xbindkeys-config/focal 0.1.3-2.1 amd64
an easy to use gtk program for configuring Xbindkeys

sudo apt install xbindkeys-config


These are the steps in case it is useful to anyone. Many thanks to Mr_Magoo for taking the time to help me.

1.- In the terminal Disable default mapping for Super

gsettings set org.gnome.mutter overlay-key ''

Also, make sure the Super key isn't already mapped to open the Zorin Menu

Right-click Start Bar > Zorin Appearance > Interface > Left Super Key.

2.- Install xbindkeys on your Linux system if you don't have it already:

sudo apt-get install xbindkeys

3.- Create a configuration file for xbindkeys. This will create a configuration file in our home folder.

xbindkeys --defaults > ~/.xbindkeysrc

4.- Edit the newly created configuration file. In my case I edited it with nano, but you can edit it with gedit, or with the editor you prefer.

nano ~/.xbindkeysrc

5.- Add a configuration line for the "Super" key and the application you want to open. For example, to open the ulauncher-toggle browser with the "Super" key, add the following:


Captura de pantalla de 2023-02-05 17-05-31

6.- Save and close the file.

7.- Start xbindkeys on login.

Click on Home > System Applications > Startup Applications

In the new window click on the add button.

Captura de pantalla de 2023-02-05 17-12-32

8.- Save and restart

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.