Suspend works as shut down & asking for password twice when open after suspend

I just installed my OS Zorin 16 and everything was ok until I tried to suspend the OS.
when I wake up the system 1st is asked for the password twice then I found the system like a startup from shut down.
all programs closed like force shutdown happened.

started to think about the problem actually with the lock screen because after lock screen without suspend I found it stops the brightness script.

@Aravisian @Storm @337harvey
now I have another problem if any of you can help
before and after the login screen my screen blinks black
and after enter the password screen flashes 2 or 3 times black then reaching the desktop

Is it installed on a Desktop or Notebook?

laptop asus x750j

Does the same thing occur if you boot with the installation medium in live mode? Just wanting to rule out software issue.

didn't try yet but I'll give it a try.
I'll update you with more info ASAP, thanks for your help

@swarfendor437 I tried suspend when I'm using the os from live USB and nothing bad happened, now after installing the OS and updating everything each time I make suspend the touchpad and the keyboard not working after wake up from suspend

Just done a search and possibly an issue with the Linux kernel:

I guess that could be easily tested by affected user choosing to boot an older kernel via Additional Options at startup grub screen.

How I can do that ?

Could you try to disable "Automatic Screen Lock" and/or "Blank Screen Delay" in "Settings - Privacy - Screen"? This solved it for me. I think it could be a conflict with overlapping settings between "Settings - Power - Screen" and "Settings - Privacy - Screen".

I posted about it in a reply here: Freeze after suspend long enough - #3 by emit

The above is only meant as a reply to your quoted text, not the rest of the problems you describe in this thread.

Edit: I did not notice you are on Zorin 16 when I posted my reply. I am on 17. Sorry about that. I will read more closely before posting next time.

1 Like

I turned it off long ago I'm trying to solve the problem just

I tried sudo rmmod int3403_thermal and it's not loaded
so I can't check if it stops the dmesg spam

I suspect only for use with hardware that has heat sensors separate to SOC/CPU

Don't know if this will assist:

I'm not sure what's the relation with the problem and the temperature ?

I was responding to your last post.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.