Suspension Issues on On Framework 13th Gen Intel

I just got my machine and I've tried to install Zorin on it, for the most part, it works fine out of the box, that was until I realized that when I closed the lid the machine did not suspend. Hitting the power button would cause the OS to suspend, however, what I didn't initially notice is that when I entered suspend this way the screen would still be lit despite displaying just a black screen.

I followed the generic Ubuntu guide from Framework as well as the guide for 12th gen machines from the developers of Zorin and these did not resolve the issues. In fact following these guides actually caused other issues:

Adding the following to grub to disable the ALS to enable the brightness keys
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash module_blacklist=hid_sensor_hub"
instead of affecting brightness seems to just disable the speakers.

I also tried using echo deep | sudo tee /sys/power/mem_sleep to attempt to force the screen off when the system suspends, this did, in fact, work to turn the screen off, but it also would not turn back on when the system would awaken, additionally, it seemed as though the system would wake up (without the screen) when I closed the lid in this scenario.

Here are a couple more tips you might try on Zorin Core:
Make Ubuntu Not Go in Suspend When Laptop Lid is Closed.

Note the option about #HandleLidSwitch

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.