Switching users leads to a black screen (and possibly a system freeze)


I set up Zorin OS 16 on a HP ProDesk 400 G5 Mini (see inxi output below) and I'm running into a weird issue. I set up two user accounts, an admin account for myself, and a basic user account for my sister just so she can play Minecraft. Both of them are password protected but my sister's account is set to automatically log in since I couldn't be bothered to bypass the password requirement.

Initially I thought that I would get to the login screen, and if I tap her user account I would get automatically logged in, but instead booting into Zorin sends me right into her account. That's actually great, since I want everything to be pretty straightforward when she's using the PC without me around.

However here's the issue. Zorin boots me into her account, but I want to use mine. So I go to switch users, select my account, input my password and... I get a black screen and an unresponsive system. Switching to a TTY doesn't work, nor does any key combination except Alt+SysRQ+REISUB to force a reboot. Only once I managed to reboot with Ctrl+Alt+Del but I haven't been able to do it again since then.

After the forced reboot, I'm back on my sister's account. She's not a sudoer so can't do anything. I switched to a TTY and logged into my account, but I have no GUI so it's not ideal.

I thought maybe it's a config issue somewhere on my account (since I installed a bunch of packages, I'll detail that at the end of the post as well), so I went with the "obvious" choice. I nuked my user folder (rm -rf /home/dragonsky). That did the trick, but everything in my user folder was gone.

I reinstalled Zorin again since I wanted to find a subtler solution, now knowing something in my home folder was the culprit. I redid the exact same steps and I'm back in the exact same situation. On my sister's account, system locks up when I switch users.

I don't have any idea what config file I should delete to fix this, but maybe you guys have an idea. Or maybe you have an alternate, simpler and cleaner solution.

One fix that works perfectly is to disable autologin on my sister's account then reboot. That is nice, but I want the autologin since she's 10 and I don't want her to memorize a password and struggle to type it in just to play Minecraft. Should I disable it and maybe figure out how to bypass the password requirement? She doesn't have access to sudo and I don't want her to access anything that would require a password anyway. That way I could have her just click her user icon and press enter to log in, which is a good middle ground.

Here's the output of inxi -Faz: System: Kernel: 5.11.0-40-generic x86_64 bits: 64 compiler: N/A parameter - Pastebin.com

If it also helps, the only things I did before experiencing this bug were the following: installed the Minecraft flatpak, then went and configured League of Legends on my user account using the Reddit /r/leagueoflinux guide and then set up my sister's account. Maybe Wine is at fault? Or the packages that I installed in Lutris' installing drivers guide?

Ubuntu 20.04's release notes mention a bug with autologin on NVIDIA graphics, but I only have Intel graphics on this PC. I also read on an Ubuntu forum that the issue might also be because I have two monitors. I haven't tried unplugging one and trying to recreate the bug. I will do so later today and come back with info.

In the meanwhile, any ideas, or recommendations?

Hi and welcome to the forum :slight_smile:
Rather old thread, but there seems to be a workaround.

workaround but not the fix

i got the same problem. I think the computer didn't freeze. It just showing the bland screen for asking user to type his/her password. here is the workaround i have been using:

  1. User A switched to User B
  2. Blank screen showed up (seems like freeze on User B)
  3. Type User B's login password
  4. User B's desktop show up

This worked for me

On Z15.3 Core, I learned it is best to logout of one account then login to the second account afresh, to avoid hiccups.

1 Like

Sadly this doesn't seem to work.

Once I got to the black screen, I typed my password and pressed Enter - no reaction from the PC.

@zabadabadoo - I log out of the second account and get back to the login screen, then select my account and type in my password. Is there any other way to logout and switch accounts?

EDIT (18:55 UTC): I found a workaround. If I Ctrl-Alt-F1, I get another graphical session with a login screen. I can log into my account there, then Ctrl-Alt-F2 and logout from the first session. I get sent to TTY2, and Ctrl-Alt-F3 sends me back to my session without any issues. It's weird that Zorin has X running on two TTYs, it's the first distro I've seen to do that by default (I know on Arch you can spawn multiple instances of X with some tinkering), but I'm glad it does so.

Meanwhile I've tried unplugging my second monitor just in case that's the issue (as I've seen on some Ubuntu questions) but nothing changed.

I'm still committed to finding the exact issue, I think I will copy my home folder somewhere, nuke it again, then restore files one-by-one until I find the culprit. I bet there's a configuration file somewhere in there that causes the freeze.

I would honestly be surprised...
AutoLogin is an incomplete package that never did get the bugs worked out. Even users that try to use it with only one account (themselves) have it release a troop of gremlins.
Using it one multiple accounts with it enabled on one account...

1 Like

Ah, no wonder I've never had a good luck with auto-login.
I think it is better to use absolutely simple password like 123
rather than auto-login.

1 Like

And it makes good practice for kids on managing easy passwords.

1 Like

I mean when you put it that way, it's not a bad idea.

sudo passwd [username] should do the trick, right? I think the GUI doesn't let me use sequences like 123 and abcd.

I do not understand this statement. Which GUI?
There is no reason those cannot be used. Well... Other than being a weak password. But in your case it is manageable.

Settings > Users on GNOME. It doesn't let me use short passwords, and going for "12345678" tells me "Avoid sequences like 1234 and abcd."

I confirm passwd worked just fine though, so I guess we're done here. Except fixing autologin, but as you said, it's an entire mess that's broken on pretty much every distro ever.

Can someone explain to me what these last 2 keys are located on the keyboard ?

SysRq shares space, and is now sometimes replaced by Print Screen (or PrintSc depending on your keyboard). Mine has both labels on it.

And REISUB is just each letter one after the other. I typed it like that because of laziness, because in reality you need to hold Alt+SysRq, then press R, wait a second while holding those two, press E, wait, and so on and so forth until you press B and the system resets. You can also press them one after the other without waiting, but if you have any disk I/O operations going, it might end them prematurely since it doesn't get enough time to sync.

ohhh... Password manager in changing the password after the fact. I am following you now.
GUI... That could have been anything...:wink:
Yes, if you create a password at installation; it could be blank (just hit enter) if you want. Or just
If you want.
But changing it afterward is a different story.

1 Like

Can you even set up multiple accounts during install? Unless I missed a button or prompt, I'm unsure if you can.

The account set during install also has sudo access by default, so I obviously had to set up my account first, and make my sister's afterward.

1 Like

I've never tried...
I suspect not. It seems as feasible to do as it does nonsensical to try. But I do understand your point...
Just was acknowledging my own failure to remember that setting up a 1234 password can only be done at point of install, not after.

No worries!

I guess the moral of the story is that autologin should be avoided. I'll probably tinker with it once I get some free time to see if I can fix it, especially since removing my home folder solved the issue (so there's definitely something there), albeit at the cost of my files.

Thanks for the help!


This sounds like it was likely something in ~/.config
It is a worthwhile test in those situations to cp /.config as /.config-bkp to make a back up of it; then log out and in and test.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.