Symlinks on macOS via samba hurts Nautilus

I’m running Zorin 15.3 Ultimate. I have a macOS share to which I’m connecting via Samba. The macOS share (a ‘home’ directory) has some local symbolic links. When I open Nautilus to browse the mounted share, I get “Sorry, could not display all the contents of “…”. Error when getting information for file “/mnt/…”. Input/output error” Nautilus then refuses to show the directory at all.

When I drop to the command line and perform a long listing, I get “? -??? ? ? ? ? ? the_file” (This is fine and acceptable to me.)

Funny thing is, when I use another app, say Eye of Gnome, I get an error similar to that given by Nautilus; however, eog handles this by ignoring the offending file(s) and simply shows everything else w/o issue.

I’ve tweaked /etc/smb.conf [on macOS], adding follow symlinks = yes and wide links = yes to no avail. Regardless, my complaint is with Nautilus. If Eye of Gnome can “do it” (show me the rest of the directory), why can’t Nautilus?

Is there some way I can work around this issue in Nautilus?

You might need to check your GUFW settings. It can interfere with Samba.
Are you using smbclient?

sudo apt install smbclient


sudo nano /etc/samba/smb.conf

Add line under workgroup = WORKGROUP

client max protocol = NT1

sudo reboot

sudo service avahi-daemon start

No joy. I’ve done as you recommended and the outcome is no different.

I found the/a solution. It was not … intuitive.

No amount of editing of /etc/smb.conf had any effect. I had to make a copy of /System/Library/LaunchDaemons/, add –no-symlinks false to the command’s arguments, install the new plist into /Library/LaunchDaemons, unload the system version (sudo launchctl unload -w /System/Library/LaunchDaemons/ then load my own (sudo launchctl load -w /Library/LaunchDaemons/

I then dropped any current mount [on Zorin to the remote Mac] and setup a new one. Voila. Nautilus no longer has issuses with symbolic links. Nautilus can’t follow a symbolic link; it instead access the linked-to file. Not ideal, but it’s not an error … and Nautilus no longer shuts me out.


Not intuitive, indeed. Great work LiamF and thanks for posting this for others to see.