Synaptic Package Manager not responding

I opened Software and Updates (software-properties-gtk) from Synaptic Package Manager and when I closed it Synaptic Package Manager kept stucked that way :point_down:, everything grayed, and placing the cursor on the window shows the loading animation but even after leaving it opened for over 1 hour it never unblocked itself.

When I checked its memory usage I saw it was consuming very few, usually when a software stops responding is using a growing amount of memory or has reached the maximum available, till I have to force-close or the system asks me if wait or terminate. I couldn't close it normally, doesn't work in this cases, it's not the first time that certain windows stop responding but usually it's temporary, not permanent.I also tried to uninstall it and Software Center notified me

Impossible to remove <<Synaptic Package Manager>>:
E:Impossible to obtain the block /var/lib/dpkg/lock-frontend.
It's treatened by process 2114 (synaptic)

but probably it's normal as Synaptic Package Manager was still running after all.

If you have not rebooted yet, use the following terminal command. sudo killall synaptic

This command will require a password.

2 Likes

Moved from Feedback to General Help.

I also had an issue with Synaptic PM yesterday. It failed to start, showing a dpkg error and proposing a fix. I tried uninstalling (to then reinstall) but it would not uninstall, even after a boot. I then entered the suggested terminal command fix for the dpkg error (to do with certificates) and then Synaptic PM opened OK. I have not tried to uninstall since, but was unusual behaviour from a trusted app.

1 Like

The most recent Zorin Updates to come down the pipe included certificates and heimdal.

I think all users should run

sudo apt update && sudo apt upgrade

first thing.

2 Likes