System corrupted by update

Today I woke up with a new update to zorin-base with around 600kB size. Update is done, nothing to worry about. Then sometime after I executed the System monitor and saw this:

Imgur

I immediately thought that was the update's fault, so I restarted the system thinking that this solved the problem. Well, it gets worse. Now everything related to the system looks like that. Example:

Imgur

In addition, some programs don't work, even some third-party software just doesn't work. I'm saying that they close after open or simply don't open. The terminal opens, GIMP opens then closes, and so on; but chrome and vscode work just fine even showing the file names that the file explorer doesn't.

Chrome working just fine:
Imgur

So what do I do? Reinstall the system?

You might rename your ~/.config folder to /.config-bkp and ~/.local to /.local-bkp, then log out and in and see if the effect remains.
If it does not, then we can try to narrow down which configuration went astray.
Otherwise, some say that installing libpango solves the problem as that is the corrupted file.

It worked but any cache of any program has been wiped. Everything is as it had just been installed.

That is ok- since you saved the /.config-bkp and .local-bkp, you can transfer over configs that you are missing to the new .config and new .local folders.
Move anything from /.config-bkp to /.config that is app specific, like the gimp folder or the autostart folder...
The /.local/share/ folder will be a bit trickier. For a start, you can move over everything except icc, xorg, gnome-shell, gvfs-metadata, ibus-table, keyrings, locale and nautilus folders. Then test.

It happened again and since I renamed the folders my system is super unstable, freezing sometimes.

Renaming those folders and then restarting or logging out and in will cause the system to recreate the folders with Default Settings. IF anything, reverting to default would be more stable.
If it happened again and the system seems unstable, then your home config folders cannot be the cause.

Did you try installing libpango?

sudo apt-get install -y libpango-1.0-0

This lib is already installed.

I'm switching to Pop!_OS until Zorin OS version 16 or something.

1 Like

WOW dude, after that experience you've had, I wouldn't blame you! I too have had strange issues after updates before on Zorin OS.

I do run into the issue of an app not loading after clicking on it, after my OS has just booted in lots of times. If I wait for a bit, then click on it again, it loads.

I never did bother doing any research into the cause of that issue, since there is a work around by just waiting and then re-launching it.

I have had other issues after updating. Such as my custom mouse pointer was visable in CKB-NEXT before the update, but after the update, the curser now shows as tiny default curser while hovering over the app.

Another issue I've had, is video drivers not loading due to a kernal update, which forced me to revert back to an older kernal version so I could boot my system.

And another issue I've had recently infact, after the recent update I had to Zorin OS, is that after restarting and logging in, the OS didn't load properly.

Everything was B&W, and looked like year 2000's antiquated Linux OS design, nothing like Zorin at all! I logged out, checked the gear icon, made sure I still had XFCE selected.

You probably don't know, but I am running XFCE desktop over Zorin OS. After confirming XFCE was selected, I logged back in again, and everything was normal.

Sometimes, you just feel like your computer is trying to prank you or something, like its got a mind of its own. But we both know, its just the updates screwing everything up.

I agree, try POP OS, see how you like it. Make sure to choose the video driver version that is right for your system, and it will come pre-installed with said driver without you have to.

You can also choose which desktop environment version you want with POP OS as well. If you want a peppy experience, deffinetly go with the XFCE flavor of POP OS.

The only thing Gnome is good for is a good resource suck. lol