System freezes at login screen with old nVidia card

Hi everyone,

today I've installed the latest version of Zorin Core on my fairly old dad's computer sporting an AMD Fx-8320, 8GB RAM and a creaky nVidia GT210.

From the live-usb environment everything worked well: the screen resolution is correctly picked, the desktop environment is snappy etc. etc.

But immediately after the install whenever I successfully login the system just hangs and I can't even access a terminal session. The only thing I can do is to force a system reboot from the pc's power button.

Right now I'm writing here from Zorin's safe mode so I suppose that this is something related to my GPU.
I don't think that enabling the official nVidia drivers would help because the live-usb refused to boot with those drivers but, again, everything worked fine with Nouveau.

From the "Additional drivers" nothing is listed from safe mode so I'm not really sure what am I supposed to do.

Thanks for your help.

Did you tick install 3rd party drivers? If so, you have install the Nvidia driver as well - which doesn't support your old card. You rely on the Open Source driver instead (NV).

Welcome to the Forum!

Did you tried to change between Wayland and Xorg? To do that go to the Login Screen and click on Your Profile so that the Password Field appears. It must be appeared! After it is, You should see in the bottom right corner a Gear Icon. Click on it. You should see 2 Options:

Zorin Desktop (that is the Wayland Mode)
Zorin Desktop on Xorg

What is active, you can see at the Dot Marker. Change from one to the other an test it.