System input freeze

June 22 - I have a MinisForum HM80 (Ryzen7 4800u) 32GB DDR4 1TB NVME system. Had trouble with Windows with the system crashing randomly when streaming. Sent the unit back and received a new one. Decide to try Linux. All works fine and video streaming works fine. System input (keyboard - both USB and Bluetooth) - occasionally freezes when playing sudoku (installed and updated). Has the same problem occasionally when viewing the software folder. Carried out the memory and NVME check as suggested all OK. Also updated all software and kernal via the terminal. New to Linux so learning fast. Any suggestions?

I'm a sudoku fan myself, and play it often. I feel your pain. Have you tried a wired keyboard, or is that your USB? I have a wireless Logitech with a USB dongle, and it works fine until the battery gets low. Then it gets glitchy.

I have tried wired and bluetooth. Both have the same problem. The system is not completely frozen as there is some mouse movement but the buttons on the mouse also have no effect. Only way to get the system back is the power button.
Thanks for the reply.

Looks like you have plenty of RAM. I wonder if it is other memory that is being swamped.
You might see if turning iommu (Input / output memory management) off helps, or setting it to soft.

sudo nano /etc/default/grub

Find this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

add iommu=soft to it so that it looks exactly like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=soft"
Tap ctrl+x to exit, the editor will ask if you wish to save first, tap the y key. Then tap enter to save it under the current configuration.
If it does not work, you can try
iommu=off

There is also specific to Ryzen
amd_iommu=fullflush
amd_iommu=off

I think this has solved the issue. Set to 'iommu=off'. Tried iommu=soft first but still froze but only rebooted and did not update grub so it might work as well. I have played three games without it freezing so looking promising. Question: is changing GRUB this way have any other potential issues?

It depends on what you are changing. But in this case, no not really.

ehhh... I forgot to mention needing to run sudo update-grub... I really need to get it through my head to always include that.

That's great thanks very much for your help

Spoke too soon. Still freezing. After the last reply froze 2 out of 3 times.

In this case, I would revert the grub file to just "quiet splash" if the iommu setting is unhelpful.

In spite of your 32gig RAM, perhaps it is the Swap file that is the issue:

The last post also mentions to disable the YouTube enhancer (a likely problem) - I am not sure if this applies to you (if the problem appears when using Youtube) but that is the FIRST thing from that thread I would try if it applies to you.

YouTube is absolutely fine. Just played the same game on Ubuntu (5 games) and no problem. Just about to install Ubuntu onto to NVME dad to test but forgot to remove power socket. Dropped the screw and shorted so system is now dead. Try and sort out a repair.

Oh No. Not good working inside a machine that has power. Also I guess you did not read this advice:

Hope you just blew a fuse and no serious internal PCB track damage from short-circuit.