System Monitor not working

OK first post so pardon me if it isn’t just right. I am trying to use System Monitor as found in Utilities. When I click on it there is a very fast flash of what appears to be a screen but it disappears in the blink of an eye. I did a reinstall by doing the following ```
sudo apt-get install --reinstall mate-system-monitor

The system is up to date, no updates to install.

This is the output from uname -a 

Linux Zorin 4.15.0-112-generic #113~16.04.1-Ubuntu SMP Fri Jul 10 04:37:08 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Here is a link to lshw output (https://owncloud.cet.ecu.edu/index.php/s/2j9PStEmyeXbTkA)

Are you running the Mate Desktop on your installation of Zorin?

Yes I believe I am using Mate., and I just tried to start mate-system-monitor from the terminal and it worked. One of the most recent updates is causing the issue because I used it a week or two ago and it worked fine.
Thanks for the response
Joel

Can you check that you have mate-sensors-applet installed?

No it is not installed.

If you could, please install it.

sudo apt get install -y mate-sensors-applet

It might be related to the 4.15.0-112 kernel being run.

The link for the lshw output is not working for me…

mate-sensors-applet is now installed.
I am on release 12.4 64-bit
kernel is Linux 4.15.0-112-generic x86_64

Any luck with the system monitor after a reboot?
Are you launching each time from the terminal, the app menu or the panel applet?
If you launch from the terminal, does it ever give an error?

The kernels that I knew to work were 4.15.0-65 to 4.15.0-75 but it has been a little while…

reboot does not resolve the issue.
When I start mate-system-monitor from the terminal I see the following
joel@Zorin:~$ mate-system-monitor

** (mate-system-monitor:2611): WARNING **: SELinux was found but is not enabled.

(mate-system-monitor:2611): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

Do you have more than one monitor set up?

Another suggestion, try renaming your ~/.config folder to ~/.configbkp and log out and in. It may be a corruption in the configuration files and restarting the config folder from scratch may help. If it works, you can delete the .configbkp and if it does not, you can delete the new .config folder and rename .configbkp back to .config

SELinux has been replaced by AppArmor.

Yes I have two monitors.
changing .config did resolve the issue. I hate to loose all the things I have setup but I can live with that if I have to or I can just use terminal to start the system monitor when I need it.
THanks
Joel

Replacing the entire folder was just a Fast n’ easy check. You can transfer over all the other contents of the .configbkp folder if we can narrow down which setting affected the Mate sys-mon.
Can you please check if starting the Mate Sysmon from terminal still gives the “icons too large” error?

The Two Monitors may be related, as well.

mate-system-monitor starts from terminal and issues the same messages as before.

Ok.

That may have helped narrow down where to look in the old config folder. Nuts.
Well, as we are not in the same room to compare the folders and what saved settings are within them, if it was me, I would move over the saved settings I am confident are not related to the new .config directory. For example, (for my system) Audacious, Blender and all the other items that are unlikely to be related, but have their own config files.
This will minimize any lost settings.
gtkrc and gtkrc-2.0 can probably be moved over safely.

Ok I get the idea. I’ll get back to you when I find the offending folder. Could take a while.
Thanks
Joel

It really could, sorry. But even if you never really narrow it down, you probably can restore most of what is in the .configbkp to the new .config without trouble and still have all your settings.
I would avoid the mate-menu and mate-sessions folders.
Things like Gimp, Autostart, user-dirs.dirs and the like should be safe to restore.
Sorry I cannot help much more.