Takes too long time to install after select country

I'm new comer here to using Zorin 16. and seems stuck for more than 2 hours after doin partition and select country I stayed, making account with password. like this. and I don't see any long green percent box indicator of intalling like everyone in the bellow side of this box. is it really that long time and could be no presentage below or.. am I missing something?

Any chance that you choose download updates while installing?

yes sir, I think in the step before.. should I turn on the wifi?

Would be a good idea, but it's best not to download updates while installing. Some people have reported that Zorin refuses to install if they chose it.
You can always install the update after installation.

If you turn wifi on, you need to setup (choose router and enter password), before advancing further.

1 Like

alright sir, so.. if I want to make it install without download update while installing. could I just restart this device? and try to repeat from the first install step?

Yes. I see no reason you can't do that.

By the way, what is your computer specs?

I tried to re-install it sir! in USB drive, with this free space and partition I made. but I got this reminder box again about amount.. what's that meaning? my laptop specs here, sir :

my Linux prob

That warning have I never seen before? Have you a CD-rom attached to your laptop?

nope, sir. don't have any here, empty :disappointed:

... and the error persist after a reboot and trying to install again? What kind of installation did you choose? Are you trying to install it along side another OS?

.. I've got other OS here before, but I choose "something else" installation cause I don't wanna make it both in the same hard disk, but I want to install it on my USB, sir. and when I did partition for my USB persist like this link.. make it free space, add efi, add ext4 space and intall it over there... then I got those warning before sir. right after when I press continue to install (choose country session). link

I'm not sure you can do that? If so the error is probably related trying to install it to the USB - you can't install/overide the live USB while using it. So my guess you need a second USB stick to make the installation on.

@Aravisian have you heard of the phenomenon?

hello sir! so, finally I got my Zorin for the first time and feels great. after I tried many ways to find the main problem, and.. found my last USB is the problem like error issues😞 now everything is good as your advice as far. thank you so much, sir!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.