Taking ownership of exFAT drive?

I wanted to have a partition that can be accessed easily by both Windows and Zorin, so I formatted a part of the new 2T drive I installed as exFAT in Windows (I thought that would be a better idea than formatting it as NTFS).
I can see its contents, even mount it, but I can't modify anything on it -- I discovered that root is the owner of that drive and everything on it. So I unmounted it, then ran sudo chown istvan /dev/sdc1 (those are the correct username and partition path), it gives no errors, but the owner is still root.
I also tried "sudo chown istvan:istvan /media/istvan/Multinet/" (Multinet is the mount name) but that outright says Operation not permitted. If I run it with -R to make it recursive, it says Operation Not Permitted for each single file and folder.

How can I take ownership so that I can modify the contents of that partition?


sudo chown istvan:istvan /dev/sdc1

Or... You might try changing the ownership of the mountpoint

sudo chown -R istvan:istvan /media/media

The first one, again, produces no output, the second one says "No such file or directory"; the mount point is called "/media/istvan/MultiNet", and if I use that instead of /media/media, it says "Operation not permitted" for every single file and directory.

Doing some more digging, I found something about objects maybe being immutable, so I tried doing both sudo chattr -i and lsattr for one of the dirs on the drive, and for both, it says "Inappropriate ioctl for device while reading flags".

oh... -facepalm-
Here is your issue. I had to actually READ the O.P. :roll_eyes:

The exFAT FS does not support file ownership operations.

Oh. Hmm. Then am I better off reformatting it as NTFS if I want both Windows and Zorin to be able to read it? I know Zorin can read/write NTFS but I understand it's not ideal for Linux, being proprietary and all.

Searching the issue I found this:

I have never tried this particular solution, so I cannot say if it will work or not.

Thanks, I will try that, and if it fails, reformat the partition as NTFS, maybe I'll have more luck with that.

This worked!

1 Like

Just remember that this presents a Security Hole should you use the computer in a public place with that drive, where other people can access it.
As long as you are the only user accessing that computer in your own safe place, it should be fine.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.