Tar files and how to make them do their thing

Hi everybody. As my moniker suggests, I’m fresh off the boat with Linux/Zorin. I’m trying to open a tar file and I’ve tried everything I can see on the net with no success at all. One thing I’m really trying to figure out is how to put a “directory” into the terminal.

Anyone lend a hand?

The archive manager should be able to extract it - right click and select Open with other application.
What exactly are you trying to do? Install an application? If so, which one?

1 Like

To install a tarball, the steps are usually to extract the file as Carmar explained above. Then you can open a terminal in the directory which there are many ways to do. With my file manager, I can right click anywhere in the window and select “open in terminal”. It is also a button on the toolbar I can set in settings to be present.
Or, hit the keys ctrl+alt+t and then use the Change Directory command

cd

If you downloaded a file, then it would land in your Downloads folder, same as it does on your average Android phone. So just typing the path, including the exact name of the folder you just extracted, is the change directory path.
For example, if I downloaded and extracted gimp2.10.8.tar.gz, I would extract it, then cd to

cd ~/Downloads/Gimp2.10.8

The “~” is terminal shorthand for Home Directory in the path. At this point, the installation steps would be

/.configure

make

sudo make install

Which would be using the software named “Make” to run the installation.
We did not name the thing.

While these steps look involved in long typed out form, after doing it a couple times, like riding a bike, it becomes familiar and easy.

All of that said… Most things folks are trying to install these days are not packaged to be built from source except things intended for experienced Linux users or developers. Many users new to Linux will look for a needed piece of software and be led to a package that is a tarball that is no longer being maintained or is old… and run into dependency problems. And since this is a New Method to that user for installation, it can get very confusing. You almost wish that maintainers would leave a note when they stop maintaining something with the date on it saying, “Sorry, we are closed.”

So as Carmar asks above, knowing what you are trying to install can help us figure out the best way for you to address your installation.
The majority of packages folks are looking for these days are in a Repository, so installation requires only that you run Advanced Package Tool (apt) to install the software.

Thanks for replying. I’m trying to download balena etcher and the Hardinfo benchmarking software.

Thanks, that answer is really helpful. As above to Carmar, I’m trying to install Balena Etcher and the Hardinfo benchmarking software.

Hardinfo is in the Ubuntu repository, so you can enter into terminal

sudo apt-get install hardinfo

Balena Etcher comes as an AppImage which is in a Zip file. But it also has a repository you can use. Add the repo:

echo “deb https://deb.etcher.io stable etcher” | sudo tee /etc/apt/sources.list.d/balena-etcher.list

Then add the key:

sudo apt-key adv --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys 379CE192D401AB61

This way, you can remove and reinstall if needed without having to do the whole process of the appimage or compressed files all over again.
Now install:

sudo apt install balena-etcher-electron

That worked for Hardinfo, but balenaetcher ended up like this -

sudo apt install balena-etcher-electron
E: Type ‘“deb’ is not known on line 1 in source list /etc/apt/sources.list.d/balena-etcher.list
E: The list of sources could not be read.
E: Type ‘“deb’ is not known on line 1 in source list /etc/apt/sources.list.d/balena-etcher.list
E: The list of sources could not be read.

You can copy and paste in the terminal either with a Right Click and select from the menu, or with keyboard shortcuts using ctrl+shift+c (copy) ctrl+shift+v (paste).

The above error indicates a typo or mispaste or something that went wrong with the line. EDIT: Nevermind… I just tested that repo and I get the same error…

Here is the source:

shrug
Let’s kill some zombies.
First, we will remove that entry, second, (nope, see the EDIT below)…
EDIT TWO: Opening either Synaptic or Software and Updates on my machine throws that same error for Balena Etcher, then crashes closed. So using Synaptic or using Software and Updates will not work…We will do it with the file manager, manually.
Why am I not surprised… this is one of many reasons I never use nor trust Balena Etcher. It is the most Brokenest USB etcher I have ever seen.
Method One to remove (manually):
If you are on Zorin Core, you can open a terminal and enter

pkexec nautilus

If you are on Zorin Lite,

pkexec thunar

To elevate your file manager to Root. IF pkexec does not work (It is a pale candle to gksudo), then enter in terminal

sudo -i

Enter your password, then type into terminal

nautilus

For core and

thunar

for Lite.

Now, navigate to “Other Locations”
and start at Root.
Navigate to /etc/apt/sources.list.d
folder
Within that folder, you will see “balena-etcher.list”
Right click and trash /delete/ remove that . You may also see “balena-etcher.list.save” Remove that, too.
Close out the Elevated File Manager and open a new terminal and run

sudo apt update

Ok, back to BalenaEtcher- if you still want to use it…
AppImage. Extract the zip file and find the appimage in the folder- right click that and select Properties Tab, then select Permissions. Look toward the bottom of the popup window and you will see an unchecked entry for “Run as a program” Check that to “checked” and then you can double click the appimage to run it.

Here’s what happened with the balena extracted file after following the instructions you guys provided:

cd~/Downloads/balenaEtcher-1.5.116-ia32.AppImage
bash: cd~/Downloads/balenaEtcher-1.5.116-ia32.AppImage: No such file or directory

However, on following up with Aravisian;s instructions, on trying to move the balena etcher to the list, this popup came up saying it coukd not be moved to the tras, permission denied, tried delete button and had the same result. However when I ran it again, etc file had no balena etcher list, so it seems to have worked anyway.
When I tried to use it by the run command, it wouldn’t work and the permission to run as program was ticked when the file was extracted. So Balena seems very unstable. I won’t use it again.
Any recommendations for ios burning software on linux?

If you could, please check /etc/apt/sources.list.d and ensure that the balena-etcher files are not present. Remember, in order to make any alteration in Root using the file manager, it must be Elevated Permissions (Root) first.

Rather be sure those are truly gone so that they do not haunt you later with that same error popping up again when you do not expect it.

For ISO burning, I always use Unetbootin. On occassion, I will use multiboot.
Add the repository:

sudo add-apt-repository ppa:gezakovacs/ppa

Install

sudo apt install unetbootin

(It’ll work fine).

On a side note: I am compelled to point out that it is not proper to try to run any program from terminal with “bash” as a command to run it.

Checked; no Balena Etcher. Will give Unebootin a try.

Thanks for all the help. You folks rock!

1 Like

Tried Unetbootin. I’ve used it before on Microsoft, but I’m lost with it on Zorin. It asks for me to find a mount point for the usb, I’ve tried mounting it but no go. Lost!

Plug in your USB, then start Unetbootin - it will automatically select the USB since the default option of when it starts is the USB.

1 Like

So steps so far -
Launch unetbootin
Select usb
Load iso file
click ok

Request to mount. Mount to /media/etc, doesn’t recognise the mount.

Then try different usb. If I chose a listed distro, says there is no usb. If I change to disc image, sees the usb but requests format to FAT 34.
Format to FAT, unetbootin does not recognise the existence of the iso file which is sitting in downloads.

Download the ISO that you want to burn (assuming you have not already.)
Insert your USB drive.
Next, open Unetbootin.
You can ignore the top part, entirely.
Toward the bottom, you will see a tickbox and “DISKIMAGE”.
Tick that box. ISO with a drop down menu can be left as is… to the right a bit is the File Box; select the Drop Down Menu that has the ellipses on it to Browse to the ISO you want. It opens at Root. So just select that drop down menu from the top address bar and navigate to /, then to home, then to your User name, then to Downloads, assuming that is where your ISO is currently. If it is in another location, navigate that path, instead.
Once that is done and back on the Unetbootin Window, you will see type - USB Drive and Drive- which should have sensed the USB drive and filled in with something like sdb1- so then you need only click “OK” to burn.

Ok thanks. The process went fine but the iso didn’t burn despite Unetbootin going through it’s process steps properly. (At this point I was going to partition and add manjaro to try out an Arch program).
The data page said 'Welcome to the grub!"
and then stated there was an error.
The USB is new, and I loaded other stuff with it so that’s not it. I’m going to give this a rest for now, or find someone still using microsoft and burn from there.

The USB being new and having other stuff doesn’t guarantee that it is ok. I’ve used Unetbootin to install Zorin on 4 PCs with no issues. In contrast, I have seen threads where purportedly good USBs turned out to be the source of the problem. I recommend trying a different USB.

1 Like

This is actually the very first time I have ever seen a user report an issue with Unetbootin.