Taskbar icon question

Hello everyone, I have a question about the taskbar and it is that I need icons of open programs that run in the background, something that is usually seen in Windows with the icons on the right side of the taskbar, next to the icons of internet or volume and if I remember correctly in Ubuntu. Is it possible to have these icons active?

If you are using ZorinOS Core, you may want to look into this Gnome extension:

I found this other thread I think relates to your issue, that suggests a different approach:

Do you mean to show active applications in the taskbar?

If yes
Right click on taskbar -->taskbar settings -->Behaviour -->show running applications

Digging around I found that gnome developer's decided to do away with system tray.The new implementation is appindicators (we have Zorin appindicator)

Here is a thread discussing the differences


what you call ¨indicators¨ is what I am looking for, exploring the forums that @zenzen has sent I have realized that it is actually enabled but due to some error in GNOME it is only activated when the user closes the session and starts it again, allowing getting the taskbar to refresh, it also works with alt + F2 and typing r to execute a command that restarts GNOME

1 Like

I'm curious about this bug since I remember at least a few programs that did create the system tray icon normally without having to tweak or install anything. Are you running them as flatpak perhaps?

Right click the taskbar and add widget. Look for the app icon widget and drag it where you want it.

If it's not in the list, choose the get more widgets button. Type appicon in the search bar and download. Then follow the above process.

What application are you running?

It seems that I am not running a flatpak type program

It seems that it is not a program problem, it is a GNOME problem, since as I mentioned before when restarting GNOME the program is shown. In any case, I think that the best thing to do right now is to wait for an update that corrects the problem

Can you give an example of what program does that? I tried with KeePassXC and I see the tray icon when I minimize it.

The error occurs with any program, such as Steam or Discord. Certainly I have also noticed that there are extensions that should also have their space on the taskbar and only appear when GNOME is restarted, but there are other extensions that do not cause problems when activated, such as OpenWeather

Have you yet tried:

sudo apt install --reinstall gnome-shell-extension-appindicator


1 Like

I just installed Discord from the Software Store as a flatpak, and then later from their website as a deb package, and both times I see the tray icon. Note that due to the light theme there's very little contrast and the icon is barely visible:

Maybe re-installing the gnome shell extension as suggested above by Aravisian may help.

When you open a program you can easily see that it's active on the main taskbar container but then you can customize its position, size and program buttons as you wish, also to make active programs more noticeable (for example making them display their name to see a longer and well visible icon). All I found on Software Center to make icons appear on the tray icon are probably KDocker and AllTray. By the way, it's up to the package owners to set that the program will load its own tray icon. Luckily some knowledge and some extensions can do the trick.

I did the same as you, I did a clean install of Zorin OS 16.3 Core in a virtual machine on my main PC, I have installed Discord in Software and when I open the program the Discord indicator shows without problems in the taskbar

I just did it and restarting GNOME has not fixed the error, the program indicators still do not appear

Are you able to note which software does not consistently appear in the app indicator tray?
Is it the same software each time or does it vary?

Steam and Discord at the moment, I don't know if other programs I use leave an indicator visible in the taskbar

Hmmm... I use both of those and both are the .deb version installed. They consistently remain in the indicator (Though I am using Zorin OS Lite, not core) without trouble.

We already reinstalled the gnome extension.

Both of these imply it is not the .deb version of the package, nor the gnome-extension.

They are available as Flatpaks. Are they both installed from Flathub?

Well, I've made a couple of changes to the system but the commands I found destroyed GNOME and the commands to try to fix it didn't work, so I reinstalled everything with an updated system image (version 16.3) and I no longer have the bug, thank you everyone for the help they gave me (in case you were wondering I didn't lose any information, I was able to get all the important information with the USB live so everything is in order). The help you provided is appreciated even though I could not solve it without having to reinstall the system