Taskbar moving up on its own after screenlock

Hi,

I switched from Windows 10 to Zorin (clean install, no dual booting) and I’m loving it so far.

I have a simple issue here: when my PC is inactive for a while, the screen locks up. I enter my password and then I see my taskbar switched positions upwards instead of staying down. It stays that way until I restart, then it’s back to its original state.

I have the default layout and no themes. My system is up to date.

Any idea how to fix this?

Here’s my system info (if you need more I’ll provide):

Distributor ID: Zorin
Description: Zorin OS 15.3
Release: 15
Codename: bionic
OS type: 64-bit
Memory: 6.7 GiB
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Graphics: Intel® HD Graphics P630 (KBL GT2)

Welcome, dragonaut.
Can you go to System Tools -> Synaptic Package Manager? If you don’t have it, enter the terminal (ctrl+alt+t) and type sudo apt install synaptic to install.

Once you fire up SPM, use the Search feature to look for “taskbar” (without quotes). If you sort by Installed Version, you should find ‘gnome-shell-extension-zorin-t’ and a version number. Right click on this entry and tell me what options you get.

I get the following:

Unmark (greyed out)
Mark for installation (greyed out)
Mark for installation (clickable)
Mark for upgrade (greyed out)
Mark for removal (clickable)
Mark for complete removal (clickable)


Properties (clickable)


Mark recommended for installation (greyed out)
Mark suggested for installation (greyed out)

Do you mean Mark for reinstallation is clickable?
Go ahead and Mark for reinstallation (or installation, whichever one is clickable), say yes to any new messages and then click Apply. Once its done, try your screen lock and see if the problem reappears.

Sorry yes, I meant “reinstallation”. I did it but the problem still happens. I tried it on my home and work PC and they both replicate the same issue.

Interesting that it’s happening on both computers but I’m not sure what to make of it.
Can you try reinstalling “gnome-shell-extension-zorin-panel” in Synaptic?

I tried it on both computers again but it still happens. Weirdly, I found out that the problem happens only if the screen is showing the desktop before the screenlock. If it locked on a window like Chrome it doesn’t happen. My solution as of now is to disable the screenlock altogether. Thank you for the help carmar.

You are saying that your panel jumps to the top and remains there after unlocking the screen, correct?

Is this top-placed panel identical to the normal bottom panel? Does it contain the Zorin App Menu and all the applets you normally have?

Hi,

Sorry for the delay. Good eye! It does contain the same Zorin Apps as the normal one, but in addition to them it has the date too (which is absent from the normal taskbar). I think it looks the same as the “taskbar” that is visible during the lockscreen (which is located on top).

For reference, if anyone else is having the same problem, I found out it goes back to normal using ALT+F2 -> r, so to me this is no longer an issue.

Thank you guys for all the help!