Taskbar not showing applications running in background

Hello good people of the Zorin OS forum.

I'm fairly new to Zorin OS, so far I enjoy the experience coming from Windows 10.

What I'm experiencing is an issue with the taskbar, where the background applications that start with the OS are not visible. For example I installed Flameshot with the software manager, and with the Startup Applications app. The command to start it is: /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=flameshot org.flameshot.Flameshot.

Thing is, this worked a few days ago, and after some update of the system, it stopped showing up in the taskbar. The process is running, I can see it under processes, but it does not come to focus (even ALT + Tab). I can't get to the UI of Flameshot. The same goes for DropBox and NextCloud.

So I doubt it's a Flameshot thing only.

Here is my machine info from neofetch:

OS: Zorin OS 16.1 x86_64
Host: 81YQ IdeaPad 5 15ARE05
Kernel: 5.13.0-39-generic
Packages: 2922 (dpkg), 47 (flatpak),
Shell: bash 5.0.17
Resolution: 1920x1080
DE: GNOME
WM: Mutter
WM Theme: ZorinBlue-Dark
Theme: ZorinBlue-Dark [GTK2/3]
Icons: ZorinBlue-Dark [GTK2/3]
Terminal: gnome-terminal
CPU: AMD Ryzen 7 4800U with Radeon G
GPU: AMD ATI 03:00.0 Renoir
Memory: 2221MiB / 15358MiB

I rebooted the laptop a few times, and It got working again, but then in the next reboot it's not.

What I can see in my logs:

22:40:55 systemd: Failed to start Application launched by gnome-session-binary.

22:40:55 systemd: Failed to start Application launched by gnome-session-binary.

22:40:53 systemd: Failed to start Application launched by gnome-session-binary.

22:40:52 gdm-session-wor: gkr-pam: unable to locate daemon control file

22:40:45 smartd: Device: /dev/nvme0, number of Error Log entries increased from 2736 to 2738

22:40:43 kernel: integrity: Problem loading X.509 certificate -65

This is a known Gnome bug and unlikely to be related to your issue.

Please run

sudo apt install --reinstall policykit-1-gnome ca-certificates

Thank you.

I did run the command, the error is not appearing anymore.
But my initial problem is still here, Flameshot does not appear in the taskbar on reboot.

I noticed this with stacer. I have it set to auto start, but it wasn't (deb package). The apps that you are starting at boot, open them (launch them manually) and it should resolve it. I don't know what was changed (security update) but it seems that boot apps need run prior to working in the startup app file.

1 Like

Is this exclusive to Gnome-Shell?

I tried to execute the command that was automatically added for the startup up in the console:

$ sudo -i /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=flameshot org.flameshot.Flameshot
Gtk-Message: 17:05:08.611: Failed to load module "canberra-gtk-module"
Gtk-Message: 17:05:08.611: Failed to load module "canberra-gtk-module"
QApplication: invalid style override 'adwaita' passed, ignoring it.
	Available styles: Breeze, Windows, Fusion
flameshot: error: Unable to connect via DBus

How can I help you, to help me? :slight_smile:
What logs can I provide or what do you need from me, to figure this one out?

I know this is not the solution, but to quickly see what's running, I use the hot corners for this. Moving the mouse up to the left upper corner. show all the applications in use, even though they don't show on the taskbar.

If you're using core, you could also look in the taskbar settings and see if the option > " Show running applications" is turned on.

I just removed the Flameshot from the startup applications, and now I really wonder how I managed to add it in there at all, since I didn't type usr/bin/flatpak run --branch=stable --arch=x86_64 --command=flameshot org.flameshot.Flameshot, I do remember selecting the application from a list.
Can't reproduce this now. Anyway, Flameshot works now when I start it manually, so I will leave it at that - no autorun for now.

Yes, this was on the whole time.

I would say let's close this topic for now. Might be a fault on my side with how I added the apps to the Startup Applications.

I'm unsure since I'm running gtk and kde. A lite user will have to comment if their startup apps aren't working.

Ok, I figured it out how I added Flameshot to the startup. I used Tweaks.

and then it appears in the Startup Applicaitons

with the command I posted in my initial post.

Still not starting up at boot.

Also noticed, that Remmina is not starting either.

I have never heard of an item added to startup not starting at boot. So, I tried a net search on this issue and came up dry. This is something new...

I'll have a fresh install planned soon. I'll report back if this behavior happens on a fresh install too.

Ok, just finished complete clean install. Everything works fine so far.