Taskbar text turns white in light mode

Hi everyone,
I'm adding a picture of the problem. When I don't have any app opened, the text in taskbar turns white. When I open something, its black how it should be. Don't you know how to fix it please? Thank you!

Does it apply also to the items in the menu, or is it only the panel on the right? I wonder if this started happening after installing some new icon set or font, maybe?

In any case, you can quickly try a couple of things to at least start testing the waters:

  1. Press Alt+F2 and then type r to refresh the workspace.

  1. Under Zorins Appearance -> Interface -> Taskbar Settings -> Position, remove the "Date menu" by clicking on the "visible" button and enable it back.

Hi, I tried restarting the environment and removing time and it didn't work. Also, I never really changed icons or fonts and it only applies to taskbar, nothing else.

Is it something that has always happened since you first installed ZorinOS? If not, when did it start: after some update, installing something, changing themes, etc?
This looks like it's something specific to the taskbar or perhaps the themes. Did you install any Gnome extensions?

Try to to go Zorin Appearance -> Theme -> Other and click on "Reset to defaults".


Do you have any transparency options enabled for taskbar - if available? I don't have lite to know..

Sounds like the theme got kinda confused somehow by something. Have you updated recently?

Second the reset to defaults - maybe try enabling some other themes and going back to the one you're using now. Have had some hiccups with theme elements; swap some settings around or reboot and they kinda disappear.

I see in your screenshots, weather is in one, but not the other - and oddly enough not in the one with the white text :thinking:.......... Have you opened weather or set any locations? I'm not too sure but, seems kind of like weather might be doing that.

The thing is, I always used dark mode so I don't really know when it started to happen. I never changed themes or icons, I restarted appearance to default. And I also tried to deactivate all extensions and nothing seems to work.

What are the contents of ~/.config/gtk-3.0?
Do you have a gtk.css file in there?
If so, what does it include within that file?

cat ~/.config/gtk-3.0/gtk.css

I'm sorry, I'm not a big user of terminal, but it says there is no such directory or file.

Maybe that is what's causing this, as that file should be part of the default ZorinOS installation.

As you can see it's not too long so you can try to create it manually and restart, hopefully that will fix the problem? If you don't want to use the terminal it's fine, you can navigate to that location from the file manager just make sure to toggle "Show Hidden Files" as the config directory is typically hidden (every file and folder that starts with a period is not visible by default).

EDIT: completely wrong and bad advice :sweat_smile:

Actually... it isn't.

I do not know why you have one... But the default Zorin OS Installation does not use ~/.config/gtk-3.0/gtk.css and relies entirely on the Zorin Themes.
In default, there should not be a ~/.config/gtk-3.0/gtk.css file.

Then this means that a custom configuration is not changing your taskbar font color.

Since you are using the Zorin OS Taskbar Gnome-Shell-Extension and another user previously also had an error with the extension, can you please use Gnome Tweak Tool:

sudo apt install gnome-tweaks

to examine the extension and see if it has a (!) notification? Try disabling, then re-enabling it.
Or disable it, then tap alt+F2 and type in r and hit the enter key and test if the font color is changed.

1 Like

I scrolled through all the extensions, removed 3 with permanent errors like some weather one. Tried to do alt+F2 and r but still nothing has changed.

1 Like

I've been using this virtual machine mostly for testing and playing around, so I must've add it at some point for something else. Well, time to destroy and set it up again (too bad I didn't take a snapshot from a fresh install though, ugh...)

@SAFER Just another wild guess, but maybe try to disable the Taskbar entirely and re-enable it, maybe with a restart in between.

1 Like

Tried and also without a result. I really don't get it at this point

Have you installed anything notable, including KDE, packages for KDE, grub-customizer... anything you can think of?

1 Like

I don't really think so. I just downloaded few simple extensions but nothing too crucial I guess. And there is nothing that changes the look of taskbar besides the weather widget, just perfection extension and sound adapters choose extension. But as I said, I tried to disabling all of them and it didn't work.

This is a stumper.
Can you detail this Weather Widget a bit more? Right now it is the only clue we have...

1 Like

I suspect that disabling the extensions might not be enough. In the far distant past you could uninstall extensions, not any more - see if following the answer on this askubuntu thread helps by actually removing the extensions:

So, given how we're basically guessing at this point I have to ask, if you revert back to dark theme do you still see this issue happening?

Okay so I uninstalled "Just perfection" and "Weather in the taskbar or whatever its called" exntensions. Didn't work. Also, switching between dark and light mode doesn't work, that's what I basically do all the time now when trying it ahah. Yeah I really don't know. Maybe with updating to possible Zorin 17 can fix it in the future.
By the way, I also see that Zorin menu logo goes white as well.

In your Appearance Settings, you should have the option to set the theme for Controls, Icons and for the Gnome Shell.
What theme is the Shell set to?
Under Layouts, which Layout are you on?