Telegram Does not Update it just Sits on Installing

There was an update for Telegram so I clicked on update and then rebooted. When I came back up it is still in an
installing status.

I noticed one issue that said needed to install from SNAPS and not Zorin software repository. Why is this and should I now uninstall and install from Snaps. I will lose all of my customisation.
Zorin 16 Core.

The Software Store offers Snap, Flatpak and regular Debian packages.
However, Telegram is one of a few apps that, to put it the only way I can... force the users choice.
It is only available as a snap or flatpak. It is not as though Debian packages are somehow incapable of handling later versions of packages.

This is a common problem with the Flatpak Telegram- and other Flatpak packages; Forever Updating or Forever Installing.
In some cases, in spite of the spinner claiming an ongoing process, the application has fully installed or updated. But not in all cases.
You might check if the Telegram app lists itself as the latest version or not and if it launches and runs successfully.

I think pretty much everyone here hates snaps for mainly 3 reasons anyways soo:

  1. it is technically limited to 256 packages at most
  2. it slows down boot as it has to mount every single snap, similar to a .iso file you downloaded from the internet for instance
  3. there are already alternatives which do it way better, see: Flatpak

so generally, I'd say just use the Flatpak version of Telegram, I do that as well and it works like a charm :slight_smile:
you can do so by going into the software center > Telegram, and then at the top right selecting Flatpak/Flathub as the source

though, should you have issues updating Telegram from the software center, you can always manually do so by pasting this into a new Terminal window:

flatpak update
1 Like

My telegram had been installed using the flatpak version.
So based on some research installed Telegram using the following command:-

$ sudo apt install telegram-desktop

This worked and now looking to see if there are any updates for Telegram there are none.
It all seems find now.

the repo's version of Telegram is old enough that a LOT of messages will not get shown.

excuse me, that isn't Telegram, that's Virtualbox.

I sent the wrong one. Sorry!

I have Version 3.11 installed and that is about 7 versions behind.

So could I just update it manually to keep up or what would you suggest when the flatpak version had problems with the hanging on installing?


I managed to remove the old Telegram 3.11 and installed the new 3.52 from flathub. However I do have the updating issue where it just hangs and says it is installing.

Is this something that I need to just ignore for now?
When a new release comes out that I need I can just remove the old and then install the new one.

I still have the Telegram update still sitting in installing status. What can be done about this as it is a bit annoying and I dont know if can effect and other installs or running software.

If it is not Flatpak or Snap, you might try

chown -R $USER:$USER /opt/telegram

Remember to replace $USER with your username.

It is the Flatpak one as that is the current release 3.5.2 the one in Zorin in 3.1.1 which is quite old so I need the flatpak one. I just did a test. I allowed Zorin to update to 16.1 and then removed and installed telegram and still the same problem.

Can I seek support from Telegram themselves?

Yes, I would seek all resources. We can try to be helpful to Zorin OS users, here, but we won't necessarily be able to troubleshoot all independent applications.

I would like to add that the flatpak version of Telegram that I use had the same issue. For some reason that issue does not exist anymore. This problem existed in Pop! OS as well, until a few days ago when this stopped happening.
My telegram version is same i.e. 3.5.2

1 Like

Try this to update telegram:
sudo flatpak update org.telegram.desktop


I just tried to update and succeed

Thanks for responding.

I am now running on Linux Mint as I needed support for my HP Printer which did not work on Zorin after much effort to try and get HPLIP to work.

Also telegram works fine on there.

Thanks again

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.