Terminal won't start

Cannot launch Terminal (gnome-terminal) all of a sudden. Nothing manually was done really that I can think of. Tried following this article but cannot login in tty mode with my main account. Just a quick flash of a new screen (error message?) then back to tty login prompt.

Using another terminal (guake, Terminated) renders the same result = won't start.
Created a new admin account and the terminal app works so there's def something with my main account. Ideas?

Tried reinstalling gnome-terminal in Synaptic but it didn't help.

Can you please renaming
~/.config to ~/.config-bkp

Log out, then in and test...

That solves it, unsurprisingly. :slightly_smiling_face: So what could cause this?

It could have been a corruption in the saved settings used for the Terminal Emulator. Perhaps a save didn't write properly. Or a configuration caused a conflict in the running of the terminal.

Restored and renamed only ~/.config/fish and that seemed to launch terminal again. Manually running fish and I get this:

fish: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

So something broke fish, probably an update.

Reinstalled fish and disco. Unclear what caused it.

1 Like

I use Oh-My-Zsh, instead of fish, actually...
It's only annoying issue is when it connects to git -which I prefer disabled. It really delays terminal launch.

Generally, checking the ~/.config is the First Stop solution for most. Isolating it to the package as you did is even better. Sometimes, there's no telling what went wrong in the configs. But you key clue was that it worked on another account.:wink: