That thing on the taskbar icons

Opening one software and switching to another or clicking on the desktop before the software has been opened its icon in the taskbar will not show the little line on the bottom side, that marker, or whatever it's called. :person_shrugging::smile:.


It appears easily though, for example by switching to another software and then returning.

Is it supposed to happen or the fact that the white line is missing indicates that the window hasn't been used yet?

Do You use the normal Zorin Taskbar that comes with Zorin? If yes, it is normal Behavior. The active Window/Program in the Foreground has the complete Line. Other open Windows that are not actively in the Foreground used, only have this little Dot in the Middle.

If You want to have it in another Way, You could use the Gnome Extension Dash To Panel. There You have more Options to set it up.

1 Like

He pointed out that the dot is invisible when opening the program and clicking on desktop or on another program though, I doubt that is intended behaviour

2 Likes

Oh, the Dot! Because @Luca_Pavan wrote from the missing Line, I thought he or she means that. So, I have missunderstand that. Thank You for this.

To @Luca_Pavan :
Sorry for this Missunderstanding. Did You tried to reinstall the Taskbar?

1 Like

Yes.

Exactly, but when the line is missing? That's it. If you want to see this on your own you can open a software that you know taking some seconds to display a window and immediately click on the desktop or another active software and if it's as I think you'll see it, too.

Well, unless it's confirmed that's not supposed to happen as even Sorro thinks, I don't feel the need of reinstalling the taskbar (I didn't even know that's possible to do). Moreover, by what I remember, this thing is happening since my first time in Zorin OS Core so no update could have added this bug (to me, bug unless proven otherwise).

1 Like

Okay, I tried to reproduce it but maybe I was too stupid for this. I didn't got the Problem. But if You want to try it with a Reinstall open the Terminal and type:

sudo apt reinstall gnome-shell-extension-zorin-taskbar

1 Like

Maybe because you have a very powerful computer :smile:, in mine any software takes some seconds to open so I have enough time (maybe too much :face_with_diagonal_mouth::rofl:) to click on the desktop to move the focus there instead of to the software that is going to show up. I also tried the command but no change :person_shrugging:. Good thing that at least taskbar configuration wasn't lost :slightly_smiling_face:.

No, haha! I have only a Ryzen 3200G (a bit OC). It is not very powerful but for normal stuff like Internet, Mail and Streaming it is okay.

Okay, then it seems that it is some kind of bug maybe. You could test it. I named the Gnome Extension Dash to Panel. This is the same like the Zorin Taskbar but more customizable. You could install it for Example with the Extensions Manager and test if You have on this the same Issue.

My laptop takes a while to open software aswell (firefox takes around 10-20 on first launch, 3 seconds to reopen once it's been loaded to the ram). I remember seeing the issue you pointed out about the dot not appearing on my laptop at some point too, but now I can't seem to recreate the issue, no matter how much I click on the desktop while firefox is opening

1 Like

After launching Firefox click on the desktop only once, just to prevent clicking Firefox window by mistake :wink:. By my tests, a single click is clearly enough to move the focus back to the desktop.