"the efi file system creation in partition failed" - Zorin OS UEFI-Installation

Hello Zorin Community,

I'm a long time Windows user and not that knowledgable about informatics. I really wanted to try out Zorin since it seemed user-friendly and easy to install, but here I am struggling with the installation.

Here are my specs:

Acer Aspire 5 (A515-55-50QW)
Intel i5-1035G1
no OS installed except eShell (Linux)

I flashed my USB-drive with Balena Etcher and booted from usb which has worked until I needed to specify the partitions for installation:

Since I have a UEFI-based system (I believe) I first created a EFI System Partition with 512 MB in size and then a Ext4 journaling file system with 20000 MB and Root partition (/). After continuing an error appears on the next screen:

"the efi file system creation in partition failed"

I tried a lot of variations but I can't get passed the partition part.

Would be really glad if anyone got a solution for this problem.


First, try plugging the USB drive into a different USB port. Surprisingly, this is all it takes much of the time.

You may also need to go into the BIOS (EFI) settings and change UEFI Boot Option Priority to the name of the USB. For mine on my Acer Aspire, it was (efi) PNY ... You should be able to ID it pretty easily.
You may see that come up in from the Boot Menu, just select the appropriate one (Or try both).