The problem with the Zorin UI

Zorin OS handles modal windows in a very weird way. The modal windows can't be moved independently of the parent window. Here is a demo video of the problem:

This is a problem that was bugging me since Zorin 15.3. I originally thought that this is an issue present in Gnome and it's like this across every Gnome based OS. However, after testing several other distros, I came to the conclusion that Zorin is the only Gnome desktop OS (that I know of) that implements this feature. I'm surprised that no one has ever complained about it.
This is how modals look like on basically every other distro:

I wonder if this was a deliberate choice or not. But regardless, this is something that annoyed me a lot as I couldn't move modal windows out of the way to read a label or something. It disrupted the flow of work and subsequently the productivity.
I will tag @zorink and @AZorin to bring this feedback to their attention.

2 Likes

Try press the upper left button in LO and pick view --> user interface.

This issue is not exclusive to Libreoffice. I only used Libreoffice to demo. This problem occurs with virtually every modal window in any application.

1 Like

WOW, that is a weird issue indeed. And now that I am testing SPOILER ALERT! Zorin OS 16 PRO on a dual core machine, we can be on the same page for once lol. Hopefully, the Zorin team knows what to do about it.

1 Like
4 Likes

It's just how Gnome does things, I also have this, and it didn't bother me. You can change it if you don't like it.

1 Like

I'm not sure if that is the default Gnome setting. If I recall correctly, even in Fedora the Modals were not sticky.
But regardless, I don't see the point of the modals being sticky, except them being annoying and in the way. Zorin comes with a lot of Gnome optimizations right out of the box. I think this could be added to this list as well.

2 Likes

It is the default Ubuntu setting...

3 Likes