The sims 4 - Steam

Good day,

I am using Zorin OS 16.3.

A week ago I tried installing the sims 4 on my 512GB SD card through steam.
It did download, i clicked on launch, it showed its launching, and boom... it did not launch, no screen, no nothing, just the button "launch" showing again later on again, as many times as I tried, it just didn't launch, for example I managed to run Pixel worlds with proton, euro truck simulator 2 also, with some crashes though.

I deleted the sims 4 now, have you got any tips on how to download it so it could launch.

Is it a common bug, and maybe it is fixed on Zorin OS 17, and I should wait until I can upgrade?

I am not looking forward to switch to Windows 11, even though I am running on dual boot, since I am using Zorin OS for only 2 months or so now.

Thanks guys for reading my post.

I hope you can help me!

I am having this same issue and even started a thread on it.
From what I can tell - this is purely a Steam issue.

I resolved most (But not all) of these when I completely reinstalled Steam from Scratch - which necessitated re-downloading and installing games... (sigh).
Astroneer currently is the only remaining title in my steam that suddenly does exactly as you describe.

1 Like

So you mean just delete all, and download it through the app store, or terminal?

Yes, sadly. I removed all of Steam however I did back up my game save files into a new separate folder that I restored after reinstalling Steam from APT (Either Software Store or terminal).
I only backed up specific files and only for a couple of titles.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.