Thinkpad t14s AMD issues after woken up from sleep

So when my laptop goes to sleep then I wake it up by moving the mouse or opening the lid, it turns on and goes to a gray and black screen.

Here's my log messages

 7:00:36 PM systemd: Failed to start Network Manager Wait Online.
 7:00:05 PM kernel: acp_pdm_mach acp_pdm_mach.0: snd_soc_register_card(acp) failed: -517
 7:00:04 PM systemd-udevd: /usr/lib/udev/rules.d/39-libtvcontrol.rules:4 Invalid value "/bin/sh -c 'for I in /sys/bus/usb/drivers/cytherm/$kernel*; do echo `basename $I` > /sys/bus/usb/drivers/cytherm/unbind ;  done'" for RUN (char 79: invalid substitution type), ignoring, but please fix it.

The only way to get it boot properly is fully shutting it off and turning it back on again

There are several things that can cause this.
Are you using a dedicated Nvidia Card?
Do you have gnome-screensaver installed?

As we await answers to those, you might also reset GDM

sudo gdm3 -reset && sudo reboot

Or reinstall

sudo apt install --reinstall gdm3

No Nvidia card but gnome screensaver is installed(I think by default on Zorin OS 16 Pro), and it dims my screen when not in use

Screenshot from 2022-01-21 09-22-46

Using the Zorin OS 16 Pro
And this computer

You may try the Oibaf graphics driver:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

if it doesn't work, how can i revert the changes made?

That is a good question. You can remove the PPA and then simply install the AMD drivers or run a very complicated:

dpkg-divert --package libdrm-common --divert /usr/share/libdrm/amdgpu.ids.divert --rename /usr/share/libdrm/amdgpu.ids

And removing the PPA and installing AMD drivers would be what command? Also, what do you think the issue is? And do you expect it'll be fixed in an upcoming release. Cause it worked fine before.

Can you clarify this statement?
If it "worked fine before", do you mean before an Update?
If so, this implies that the latest Kernel is the culprit.
The AMD drivers are included in the kernel.
To remove the oibaf drivers:

sudo ppa-purge ppa:oibaf/graphics-drivers

To remove the ppa:

sudo add-apt-repository --remove ppa:oibaf/graphics-drivers

Installing the AMD drivers requires going to the AMD website and downloading them. However...
This brings us back to you saying that it worked fine before... Suggesting that the drivers contained in the previous kernel may have been working.

To roll back to a Previous Kernel, please see:

I am unable to be at the computer right now for more than a couple minutes at a time. If you run into trouble or have questions, please ask but be patient for someone to reply.

1 Like

Yea in the previous kernel it was working, I will try the rollback

Thank's issue was solved by reverting to the past kernel before the update.

The kernel with the issue was 5.13.0-27-generic
Reverted by to 5.11.0-46-generic

Side note: To enter grub (to select kernel) I found it was pressing the ESC button during reboot and not shift. At least on my laptop.

1 Like

Yep, this is yet another problem attributed to issue in current Ubuntu LTS kernels 5.13.
Fixed 5.13 kernel should be out by the end of January. Until then please stay with kernel 5.11, which works flawlessly.


That's great hopefully the main channel pushes the fix.

Issue persists in Linux thinkpad 5.13.0-28-generic #31~20.04.1-Ubuntu SMP Wed Jan 19 14:08:10 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux


Meh, that is very disappointing. :frowning:
In the meantime, I made a "leap of faith" into the unknown and migrated my systems to kernel 5.16. No issues there...
I cannot test the "fixed" kernel 5.13-28 now. I will have to install a separate test partition of Zorin/Ubuntu later on to test this.
If this kernel is not fixing mentioned issues (there is a LOT of them), I will pursue with Ubuntu dev team and/or Kernel dev team... :crossed_fingers:
Thanks for the report.

1 Like

Any updates on when a new kernel will be pushed to the main Zorin repo?

Hi. Another update arrived yesterday, kernel 5.13.0-28-generic #31~20.04.1-Ubuntu SMP.
It seems that it is fine; it fixed kernel crashes during boot and my system (Ryzen-powered HP-Envy). It can shutdown, restart and hibernate now. Also AMD Sensor Fusion Hub (motion sensor) started working again :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.