Third Party xbox controller not working

Well so I have a third party xbox controller(rpm euro games).It works flawlessly on windows but not that great on zorin os.I tried using rmmod xpad and stuff like that but it still does not work.Earlier when I installed zorin os it worked fine with xboxdrv but after reinstalling it again in my main pc.It does jot work with xboxdrv.I always get this error.I have even tried sudo xboxdrv.It detects but does not work.Please help me I dont have any money left to buy a new one.xpadneo does not work either.This is the error:
xboxdrv
xboxdrv 0.8.8 - http://pingus.seul.org/~grumbel/xboxdrv/
Copyright © 2008-2011 Ingo Ruhnke grumbel@gmail.com
Licensed under GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under certain
conditions; see the file COPYING for details.

Controller: Microsoft X-Box 360 pad
Vendor/Product: 045e:028e
USB Path: 001:023
Controller Type: Xbox360

-- [ ERROR ] ------------------------------------------------------
USBController::USBController(): libusb_open() failed: LIBUSB_ERROR_ACCESS

I use zorin os 16 64bit

Specs:
[System]
OS: Zorin OS 16 focal
Arch: x86_64
Kernel: 5.13.0-39-generic
Desktop: zorin:GNOME
Display Server: x11

[CPU]
Vendor: GenuineIntel
Model: Intel(R) Core(TM) i3-1005G1 CPU @ 1.20GHz
Physical cores: 2
Logical cores: 4

[Memory]
RAM: 7.5 GB
Swap: 2.0 GB

[Graphics]
Vendor: Intel
OpenGL Renderer: Mesa Intel(R) UHD Graphics (ICL GT1)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 21.2.6
OpenGL Core: 4.6 (Core Profile) Mesa 21.2.6
OpenGL ES: OpenGL ES 3.2 Mesa 21.2.6
Vulkan: Supported

Thanks!

I use xpadneo and it works flawlessly. I wonder if it may be worth checking it out rather than troubleshooting xboxdrv...

Thanks but xpadneo does not work either.

Is it the Same Result as the other? Same symptoms you outlined already?

Yes but the gamepad isnt even detected
without xboxdrv

Thanks but this does not work either.

Please be sure to clarify what you mean by "Does not work." That statement could mean anything.

I mean that none of the things mentioned there work.before posting here I already tried to fix my problem from your linked post.

Try using another USB port.

Well I have tried that too but no fix