Threadripper 5975wx - Install Issue

CPU: AMD Threadripper PRO 5975WX 32-core
Mobo: ASUS Pro WS WRX80E-SAGE SE WIFI (Latest BIOS and firmware)
GPU: MSI SUPRIM X 3090
RAM: 128GB
3 x NVMe (2TB, 4TB, 4TB) Windows 10 21H2 Enterprise is on the 2TB drive.
1 x 1TB SSD <--- Target for Zorin PRO OS

Note: I intend to install this on the 1TB SSD drive, but NOT dual boot. When I want Zorin I will boot to it directly through BIOS.

All checksums on the install media have been verified multiple times. I have used Rufus and balenaEtcher to write multiple USB's. I opened a ticket with Zorin support and they are unable to see a solution. They suggested I post here.

On boot, my USB mouse / keyboard wakes up (plugged directly into the rear of the mobo) and I press F2 for BIOS. I boot from the Live USB and select the normal install. I see this:

There is a third revalidation line at roughly 128 secs, but it goes by very quickly as the logo screen appears over it. After several minutes, the logo disappears and I see dozens of stdin errors followed by “Attempt interactive netboot from a URL?” but the keyboard and mouse are dead. I plugged in another USB KB at this point, but it was not detected and also dead. I’ve used both KB successfully with Ubuntu / Mint previously. I have the same issue with the Mint Live USB as well.

So I cannot get past this point in the install. Other modes selected on install gives the same symptoms. Looks like a USB driver issue, but not sure how to get past this point.

Tried turning off XHCI Hand off on the mobo, but got the same behavior.
Changed AHCI to RAID, same issue. Mobo is default settings, no OC and nothing special for setup.

Tips appreciated. Anyone here have the same hardware setup?

I have a AMD Ryzen Threadripper 3990X, Never faced a Problem like that, Did you ran another OS before Zorin?

Am suspecting the mobo rather than the Threadripper as I had a 1950x before this which did install Zorin fine.

The xhci errors tend to make me think it is USB driver related.

Is Secure Boot Disabled?
and You can Try reseting BIOS settings,

I am still having difficulty to understand if you are dual booting with Windows?

Was pretty clear. :grinning:

Windows and Ubuntu both need different types of BIOS Settings, I suppose that is giving you the Error. Running both of them together sometimes give problems. What you are trying to do is similar to Dual boot.

Check these First,

https://www.makeuseof.com/tag/fix-ubuntu-linux-pc-wont-boot/

Have you tried disconnecting/removing the Widows SSD and just have the SSD present you want to install Zorin too? BIOS should be set to AHCI for SSD. No swap file needed. Format to Ext4 and do not apply TRIM as it has been proven on You Tube that running TRIM destroys data/prevents data recovery.

1 Like

I have the exact same issue trying to install ubuntu 22 withe same mobo and threadripper pro 5995.
Did you find a solution?