Thunderbird attachment drag and drop not working

Dear community,
I know that this is not a Mozilla Thunderbird Forum, but perhaps it may be related. I have Zorin Pro 16.3 installed and thunderbird Supernova 115.2.2 installed.

What should be simple is not. When I draft an email, and wish to place an attachment, I just can't. I absolutely need click on the attachment button, then locate the file in the nautilus file explorer, then click open. Very annoying.

Has any of you encountered this problem? Related to Zorin?



First suggestion I have to offer:

How did you install Thunderbird? I see that version 1.115 is only available on the Software Store as a Flatpak, as this is still a very recent update.
Flatpak is a sandboxed package format which is why it may not be able to interact with the rest of the system.

You may instead try to use the following instructions to download and install Thunderbird manually.

Note that you may need to uninstall your current installation to avoid any conflicts.

1 Like

Hi Aravisian, I tried that and it didn't work. Thanks for the suggestion.

Hi Zenzen, I installed Thunderbird using the software store provided with Zorin OS. I didn't do any fancy stuff.

I'll look about re-installing Thunderbird. Kind of annoying these incompatibilities.

Anything else that I can do?


Before you do anything I'm curious if you can drag and drop files located in your Downloads folder, as this is one particular directory usually available for flatpaks by default.

If files from this location work, but not from any other, then you have a good indication that flatpak permissions is the problem. If it doesn't, well, it could still be a permission issue but it simply doesn't allow access to the Downloads directory either. But it's a very quick and test, and could help with troubleshooting anyway.

Regardless of the result you could try to use Flatseal. It's a program also available in the Software Store that it's used to manage permissions to other flatpaks in your system. As I mentioned this "flatpak" package format is designed to run in a sandbox environment which sometimes has this type of weird behaviors.

I have never used it so I'm not sure what advice to give you but it shouldn't be too difficult to find the exact permission that is causing the problem. Note that this is just a guess, after all, so this may not end up solving your issue but it's worth a try. In that case, I would definitely recommend following the instructions from Mozilla to install it manually yourself.

EDIT: Just installed quickly Flatseal and Thunderbird and I think this is the setting that's responsible for allowing access to particular directories. You can specify them yourself or you can grant access to your entire home folder. I guess this warrants a mandatory "proceed at your own risk" just in case, not meant to scare you off but to caution you.


Good morning zenzen.

Thank you so much for this, it worked!!! Flatseal was already installed and I simply provided permission for my home directory. Now it works.

What annoyed me though, is that by doing this, I had to re-configure Thurnderbird like a brand new installation. Took another 15 minutes or so to bring it back as I like it.

Linux does have their own set of unique challenges. Thank god that there is a community of great people like you supporting Linux newbies.

You guys are great... :heart: :heart: :heart:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.