Thunderbird Profile Problem

Hello I have the following problem.

I have my Thunderbird profile on a different hard disk.

But Thunderbird cannot load it.

Because the root user locks the directory media which I specified during the mount and does not pass it to my user.

Your Thunderbird profile cannot be loaded. It may be missing or inaccessible

Does sudo thunderbird or pkexec thunderbird, in terminal, help?

sudo thunderbird:

mkdir: cannot create directory ‘/run/user/0’: Permission denied
No protocol specified
Unable to init server: Verbindung ist gescheitert: Connection refused
Error: cannot open display: :0

Thunderbird Profiles.ini

Name=Default User

My System:

inxi -Fz
System:    Host: Bulldozer Kernel: 5.4.0-52-generic x86_64 bits: 64
           Desktop: Gnome 3.30.2 Distro: Zorin OS 15.3
Machine:   Device: desktop System: Gigabyte product: X58A-UD5 serial: N/A
           Mobo: Gigabyte model: X58A-UD5 serial: N/A
           BIOS: Award v: FC date: 12/23/2010
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       Quad core Intel Core i7 960 (-MT-MCP-) cache: 8192 KB
           clock speeds: max: 3193 MHz 1: 1619 MHz 2: 1619 MHz 3: 1619 MHz
           4: 1619 MHz 5: 1619 MHz 6: 1619 MHz 7: 1625 MHz 8: 1619 MHz
Graphics:  Card: NVIDIA GP106 [GeForce GTX 1060 6GB]
           Display Server: x11 (X.Org 1.20.8 )
           drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 2560x1080@60.00hz
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2
           version: 4.6.0 NVIDIA 450.80.02
Audio:     Card-1 NVIDIA GP106 High Def. Audio Controller
           driver: snd_hda_intel
           Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k5.4.0-52-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp8s0 state: down mac: <filter>
Drives:    HDD Total Size: 4000.8GB (17.2% used)
           ID-1: /dev/sda model: WDC_WD5000AZRX size: 500.1GB
           ID-2: /dev/sdb model: SAMSUNG_HD154UI size: 1500.3GB
           ID-3: /dev/sdc model: ST2000DX002 size: 2000.4GB
Partition: ID-1: / size: 457G used: 8.7G (2%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 1.02GB used: 0.00GB (0%)
           fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A gpu: 43C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 351 Uptime: 16 min Memory: 2238.5/11978.1MB
           Client: Shell (bash) inxi: 2.3.56

And I assume you tried pkexec too?

The disk where your profile is, does it show up under System Tools -> Disks?

Also, I’m guessing Thunderbird has an option where you first specified the Profile to exist on that other disk (you may have browsed to it during setup?) ? The reason I ask is because I don’t use Thunderbird (or even have it installed), so I’ll need to understand first how you initially pointed Thunderbird to your Profile when you set it up.

pkexec thunderbird
mkdir: cannot create directory ‘/run/user/0’: Permission denied
Error: no DISPLAY environment variable specified


Two thoughts:

  1. Can you try copying your profile to your home folder and see if Thunderbird loads with that? Just to check.
  2. In nautilus —> Other Locations -> right click on your profile disk and select Properties. Go to Permissions-> Change Permissions for Enclosed Files. Change all to “Read and write” and “Create and delete”.

So after using Sudo I deleted the directories after unmounting the hard disks.

After rebooting the computer it went on all at once.

Does that mean you tried suggestion #1 and it works? What about #2?

Proposal 2 but not quite.

I had to go to my home directory.

Then into the terminal

Start Nautilus with Sudo.

Then the folders



Afterwards restart the computer.

Then select a new profile with thunderbird -p and adjust the path there.

Since then everything is running now.