Time showing wrong on dual boot

Hi all, have used Zorin 17 for about the last month and it is the first Linux OS I have used for more than a couple of days. So far I am really enjoying it, however I do go back to Win-11 occasionaly. The problem I have, and I think I have the correct settings set, is that when I do go back to Windows the time has reset itself to UTC (or GMT). It's not a first world problem but I would just like to know why it's happening. Anyone help?

Open a Terminal window on your Zorin 17 and run the following command:

timedatectl set-local-rtc 1 --adjust-system-clock

Have just done that (not really knowing what I did). Still have the problem. It's Windows showing wrong, so would it be a Win. problem? Even though it was OK before installing Zorin.

The command that @Hercules gave you just tells Linux to use the time zone the same as Windows does... it must not be working.

You can reset it via:
timedatectl set-local-rtc 0

But before you do, try the below...

Windows uses the BIOS time (set to local time), whereas Linux uses GMT time, I believe.

Set your BIOS to local time (so Windows displays correctly), then boot into Linux and go to:

Zorin menu > Settings > Date & Time
... and adjust the time zone so that the clock shows the correct time.

1 Like

Welcome to the Zorin Forum!

Yes the different Time in dual Boot ... it is a little bit annoying. Try this:

You type the command that @Hercules wrote:

Then You change to Windows and there You synchronizing the Time. For that you go in the Time Settings. When You have done that You get the right Time in Windows and in Linux.

1 Like