Timekpr lock screen with Zorin 16.3 xfce fails

Hi all,
I had been using timekpr-next on my Zorin 15.3 Lite (xfce) installations for quite a while successfully. I used the lock option to kick my kids off the screen to avoid data loss (in case they are actually working and not playing).
Recently I upgraded all the computers to version 16.3 Lite (with the upgrade tool - by the way, this tool is wonderful, thanks a lot to the developers). Unfortunately, the lock option doesn't work anymore.
In the timekpr-next forum I found some insight (https://answers.launchpad.net/timekpr-next/+question/700420). I tested the suggested command. I worked nicely in Zorin 15.3, but it didn't in 16.3.
I'd like to keep Lite (xfce), since the computers are not the newest ones - so lightweight helps with the performance.
Is there anything I can do to make this work on Zorin 16.3? Or would that be a task for the developers of Zorin?


Think I may have found why it isn't working:

Well, this is what I quoted as well. Unfortunately, this is only an explanation, but not a solution. I was hoping someone could offer a solution, which is obviously to be found in Zorin and not in timekpr-next.

What you need to realise is that Zorin is a fork of Ubuntu and not all elements can be overwritten. It is clear the developer of timekpr-next cannot address this issue looking at that thread.

So, what you are saying is, that we'd have to wait for Ubuntu to address this issue?

Can you remove xfce4-screensaver and install light-locker?

sudo apt remove xfce4-screensaver && sudo apt install light-locker

I am a little reluctant to apply this move, yet (since I am missing some background in that area). Would that compromise the system or are these two packages exchangeable? Are there any disadvantages to this change?

Anyway, I tested this in a VBox and the logout command as described in the timekpr-next forum works fine. I don't like the upcoming message and the waiting time, but that might be adjustable in some settings to be found. I have to look into it. However, the functionality is the priority.

Thanks for leading me this direction.

I get quite nervous about suggesting a terminal command in case it causes the user trouble. So, I usually test them and double check that they are safe.
I tested the above command in my own terminal before posting it. There are no dependency issues to worry about.
However, if you are a screensaver user, then switching to a different application for use of the screensaver may mean familiarizing yourself with a new application.

1 Like

Thanks for your support. I will look into it.
Still, I am wondering why this worked in Zorin 15.3 Lite but not in Zorin 16.3 Lite. It looks like the same screensaver in both versions.
Well, well, things change and we have to change with them :pensive:

A perfectly valid question.
I have not used that particular app and I have not been on Zorin OS 15 in quite a while, so I am basing my responses on the results in this thread (and comments in the bug report) rather than direct knowledge. All the same, it is worth a quick test and see if it works.

If you look at that bug report I posted earlier it clearly states that Ubuntu changed from light-locker to xfce4-screensaver and Zorin somehow will have inherited that when forking.

This could be the reason for the change:

And causation via Ubuntu 20.04.2 here:


Thanks for your input. I looked into my old VBox installation of Zorin 15.3 Lite and found that it is not light-locker, which is installed, but it is

xfce4-screensaver/bionic,now 0.1.8-1~18.04 amd64

Now looking at Zorin 16.3 Lite I find the installation of

xfce4-screensaver/focal,now 4.16.0-1~20.04 amd64

It looks like a big version jump from one to the other installation. So, something in the xfce4-screensaver must have changed that the lock via

sudo dbus-send --system --dest=org.freedesktop.login1 --type=method_call --print-reply --reply-timeout=20000 /org/freedesktop/login1/session/ org.freedesktop.login1.Session.Lock

doesn't work anymore.

Maybe something can be done to solve this problem:

Well, I don't see anything in this list, where I feel able to implement a workaround for the usage of xfce4-screensaver. I haven't found further help elsewhere. For now, I am hoping that a fix will come through some automatic update, while I am looking into using light-locker.

The release of Zorin OS 17 is soon coming, so I wonder if waiting a couple of months on the release of Zorin OS Lite may be viable.

Only time will tell!

This is true and I should remind that my post is a guess based on trends, not a set date.

Even so, it is a reasonable estimate and given a 2 or 3 month timeframe; it may be a good option rather than a lot of struggling with a third party app.

I've made an interesting discovery. On my test VBox installatiion of Zorin OS 16.3 Lite I reverted the above mentioned workaround:

sudo apt remove light-locker && sudo apt install xfce4-screensaver

I checked te installed version: xfce4-screensaver/focal,now 4.16.0-1~20.04 amd64

Before I wanted to fiddle around with the xfce4-power-manager (for which the earlier mentioned patch actually was made for), I just tested once more the dbus command ... and surprisingly, it worked all of the sudden.
The version of the xfce4-power-manager has not changed, but obviously, some settings have changed by uninstalling xfce4-screensaver, installing light-locker and doing the same backwards.
I checked the settings in ~/.config/xfce4/xfconf/xfce-perchannel-xml/, but nothing significant is different there (I tested the small differences).
So, I am wondering where to look for the changes that happened through this uninstalling/installing procedure.

Actually, it looks like light-locker left some traces. The lockout leads to the same message and the same login screen as it was with light-locker before (another user could login directly). On the original installation, the login screen after lockout looks different (for user change you have to press a button first).

1 Like

Maybe the screensaver parent files needed to be reinstalled. Because any settings (changes) would have been in ~config.

I edited my last post - it could be traces from light-locker.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.