Tocblock error

I keep getting a weird error

Are you able to boot or does this prevent boot?

prevents me from booting, even when i boot from usb it still gives same errors after i click enter in "Try/Install Zorin OS"

New update
So I was fortunately able to boot using the main hard drive to zorin os recovery mode and after fsck and other recoveries it shows this

Are you running in Virtual?

No, i use it on main system

If you were using SSD, i would assume you did too many write cycles and it locked itself to read-only mode to prevent you from damaging it further to not be able recover any data but you said hard drive. I see some physical sector error, it could mean your hard drive is dying. It is common alert when you hard drive have to rearrange physical sectors.

It is a HDD

In that case use Disks to run some SMART self-tests:

1 Like

When i run the self test, it doesn't not complete and says "the test was failed" although i didnt cancel it

I use it only as single boot

Are you on a dual-boot? If you are, maybe Windows tried to hijack your disk by making parts of it read-only? Or it's a "wrong permissions" problem. I asked because the TOCBLOCK error is indicative that there is an issue with the Logical Disk Manager (LDM) metadata on the disk. LDM is a proprietary disk management system used by Windows to manage dynamic disks, and it is not compatible with Ubuntu or most other Linux-based systems.

Maybe you have failing RAM? I mention this because when I searched for the errors involving "Emask timeout" and "failed command: READ DMA EXT" I read that it could be indicative of issues with accessing or writing data on the disk - which is prompted by the touch: cannot touch '/var/lock/libvirt-guests': Read-only file system error you showed. I also read that faulty or failing RAM can cause errors when accessing or writing data. But, as Cedy mentioned these errors could also be caused by other issues, like a failing hard drive, the disk controller or corrupt system files with permissions issues.

Can you try to use a different Live USB to see if you get the same problem?

1 Like

Different live USB doesn't give the problem

1 Like

Well how good does this look?

Yours is also pre-fail and old age
SO how does it work?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.