TomTom - Linux Zorin 17.1 Pro

I have Linux Zorin 17.1 Pro, TomTom Go 5100 GPS navigation and the MyDriveConnect application installed.
The application installed without any problems, but when connected (with the original cable), the software does not see the device, but after issuing the lsusb command, Linux sees the device as: Bus 001 Device 011: ID 1390:5456 TOMTOM B.V. TomTom GO 5100. Is there anything I can do to tell MyDrive Connect where to access the device?

Are you using through Wine? You may need to set a registry string to use /dev/ttyUSB0 as your COM# port.

Screenshot from 2024-04-05 02-13-19

HKEY_LOCAL_MACHINE - Software - Wine - Ports.

is it enough to provide the configuration as you provided, assuming that after using lsusb in the terminal: Bus 001 Device 015: ID 1390:5456 TOMTOM B.V. TomTom GO 5100

image

should I create this setting here /dev/ttyUSB0

Do I need to restart something to make it work?

1 Like

Once you navigate to 'Ports' - right click the white area to the right, 'New string' - then name it COM5. Double click the new COM5 string to edit it, then in 'value data' enter /dev/ttyUSB0.

Close the dialogues and in terminal enter wineserver -k and reopen the application - this may or may not work. But, worth a try.. (edit) If you have multiple USB's currently mounted, you may need to change the /dev/ttyUSBX as X may be a different number to be used.

1 Like

Thank you very much for your help. I'll check it out when I have the chance. Once again, thank you very much for your help and time.

1 Like

Not a solution as such, but we have an inbuilt TomTom device that came with the car. Since owning a Fairphone 3+ I use my preferred app of Magic Earth (available for Android) and it is more efficient than TomTom - plus all World Maps are free. My preferred voice is the female Australian voice! Magic Earth also has the ability to act as a dashcam if you have a suitable cradle!