Touchpad is not detected

I recently bought a used laptop, but its touchpad is not recognized, so it does not work. I looked for touchpad in lshw and cat /proc/bus/input/devices but could not find it. This touchpad is entirely clickable, and to tell the truth, I don't know how to use it well.

What should I do? I use a trackball most of the time, so it's not a serious problem, but sometimes touch gestures come in handy.

$ inxi -b
System:
Host: hgyamada-Endeavor-NJ3900E Kernel: 5.15.0-53-generic x86_64 bits: 64
Desktop: Gnome 3.38.4 Distro: Zorin OS 16.2
Machine:
Type: Desktop System: EPSON DIRECT product: Endeavor NJ3900E v: 1.0
serial: <superuser/root required>
Mobo: PEGATRON model: NJ3900E v: 1.0 serial: <superuser/root required>
UEFI: American Megatrends v: AP4U-0705-GA7 date: 09/14/2018
CPU:
Dual Core: Intel Core i3-4100M type: MT MCP speed: 1077 MHz
min/max: 800/2500 MHz
Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
v: kernel
Display: x11 server: X.Org 1.20.13 driver: i915 resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 21.2.6
Network:
Device-1: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
Drives:
Local Storage: total: 119.24 GiB used: 9.76 GiB (8.2%)
Info:
Processes: 212 Uptime: 5m Memory: 3.75 GiB used: 1.32 GiB (35.1%)
Shell: bash inxi: 3.0.38

Below are the important logs at startup.

10:40:57 pulseaudio: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
10:38:39 kernel: usb usb3-port5: unable to enumerate USB device
10:38:38 kernel: ACPI Error: Aborting method _SB.PCI0.XHC.RHUB.SSP4._PLD due to previous error (AE_AML_PACKAGE_LIMIT) (20210730/psparse-529)
10:38:38 kernel: ima: Error Communicating to TPM chip

I am completely unfamiliar with this notebook. I tried searching it... but could not find much that I could read.
Are you able to determine the manufacturer / model of the Touchpad device?

1 Like

EPSON may be a little-known manufacturer outside of Japan. Originally a division of the watchmaker SEIKO, the company is best known for once manufacturing NEC's PC-98 compatible machines.

The touchpad is not recognized by the OS and the manufacturer does not provide any information about it. It might be possible to find out by disassembling the machine, but doing that to a laptop is a hassle...

1 Like

I only know of Epson by their Printers.
Have you tried checking xserver-xorg-input-synaptics package?

sudo apt install --reinstall xserver-xorg-input-synaptics

2 Likes

I reinstalled xserver-xorg-input-synaptics, but it doesn't work.

Many laptops contain a hardware switch to disable the touchpad. Often this works by holding down the Fn key plus one of the function keys on the keyboard. You can also sometimes I know on dells disable the touchpad in the BIOS I would check for there as well if it's disabled it's not going to be detected

2 Likes

Indeed, Fn+F9 seems to be the switch for the touchpad, but the Fn key only works in some combinations and cannot activate the touchpad.

I checked the BIOS and the touchpad was enabled.

1 Like

Just to know, is Touchpad enabled on Settings > Mouse and touchpad or not shown there at all? Then if nothing works and it's an used laptop maybe it was sold right because of undetected touchpad, so would be an hardware issue, not a simple bug. I wonder if the previous owner punched the touchpad :facepunch::grin:. Touchpad - Wikipedia, interesting, if so, sensor could be damaged.

1 Like

Laptops have many functions in one machine, and it is inevitable that all of them cannot work perfectly with an operating system that the manufacturer does not expect. I got a couple of old laptops to get a better understanding of Linux OS, and it was indeed a good experience. Thanks to all for your help.

There is a workaround that essentially treats touchpad just as "mouse" - which you may not want as it means you cannot use gestures.
Since your touchpad is not recognized at all... This really suggests it is either too new for the kernel, or too obscure.
I do not know which but... If you suspect it is too new, you can try a later kernel such as TuxInvaders mainline kernel.

If too obscure... then you may have to abide by your solution above.

1 Like

Was the laptop serviced, or did you open it? The ribbon cable may not be seated correctly, causing the malfunction.

You could boot a windows live image and check what driver is used (if it's working there), at least identifying the TouchPad.

1 Like

Does it have a button to enable and disable the touchpad ? My acer has one that's why i am asking this.