Touchpad not working on Zorin 16 Fujitsu laptop

I have tried all guides I can find on this topic but with no luck so now I try here :slight_smile:

As recommended I hereby post data from inxi -Faz, xinput list and cat /proc/bus/input/devices. In the last I can't find the touchpad. I have tried all updates and I am told everything is the newest and installed. But maybe someone else knows how to try to reinstall the touchpad?

I look forward to your help :slight_smile:

Kernel: 5.11.0-43-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.11.0-43-generic
root=UUID=17e6244c-1b0a-4c26-8a30-0bfe9f9951a2 ro i8042.reset quiet splash
Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3
Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal
Type: Laptop System: FUJITSU product: LIFEBOOK A514 v: N/A
serial: Chassis: type: 10 serial:
Mobo: FUJITSU model: FJNBB3A serial:
UEFI [Legacy]: FUJITSU // Phoenix v: Version 2.09 date: 10/26/2016
ID-1: BAT0 charge: 26.9 Wh condition: 30.0/47.5 Wh (63%) volts: 12.2/10.8
model: PTL CP651529-01 type: Li-ion serial: status: Unknown
cycles: 122
Topology: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP
arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 26
L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 13569
Speed: 798 MHz min/max: 800/1700 MHz Core speeds (MHz): 1: 798 2: 799
3: 798 4: 808
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Fujitsu Limited.
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0a16
Display: x11 server: X.Org 1.20.13 driver: i915 compositor: gnome-shell
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2)
v: 4.5 Mesa 21.0.3 compat-v: 3.0 direct render: Yes
Device-1: Intel Haswell-ULT HD Audio vendor: Fujitsu Limited.
driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c
Device-2: Intel 8 Series HD Audio vendor: Fujitsu Limited.
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20
Sound Server: ALSA v: k5.11.0-43-generic
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Fujitsu Limited. driver: r8169 v: kernel port: 3000
bus ID: 02:00.0 chip ID: 10ec:8168
IF: enp2s0 state: down mac:
Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter
vendor: Fujitsu Limited. driver: ath9k v: kernel port: 3000
bus ID: 03:00.0 chip ID: 168c:0034
IF: wlp3s0 state: up mac:
Local Storage: total: 465.76 GiB used: 23.46 GiB (5.0%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB
block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
rotation: 5400 rpm serial: rev: 1K scheme: MBR
ID-1: / raw size: 161.06 GiB size: 157.53 GiB (97.81%)
used: 23.46 GiB (14.9%) fs: ext4 dev: /dev/sda6
System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Processes: 226 Uptime: 8m Memory: 3.75 GiB used: 1.19 GiB (31.7%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: N/A Shell: bash v: 5.0.17
running in: gnome-terminal inxi: 3.0.38

And from xinput list

christoffer@christoffer-LIFEBOOK-A514:~$ xinput list
⎑ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Dell Premium USB Optical Mouse id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Fujitsu FUJ02E3 id=7 [slave keyboard (3)]
↳ Video Bus id=8 [slave keyboard (3)]
↳ Power Button id=9 [slave keyboard (3)]
↳ FJ Camera: FJ Camera id=11 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

and from cat /proc/bus/input/devices where I don't seem to find it.

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
U: Uniq=
H: Handlers=event0
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
U: Uniq=
H: Handlers=kbd event1
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
U: Uniq=
H: Handlers=kbd event2
B: EV=3
B: KEY=10000000000000 0

I: Bus=0011 Vendor=0001 Product=0001 Version=ab83
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input3
U: Uniq=
H: Handlers=sysrq kbd event3 leds
B: EV=120013
B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input6
U: Uniq=
H: Handlers=kbd event4
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0003 Vendor=413c Product=3016 Version=1110
N: Name="Dell Premium USB Optical Mouse"
P: Phys=usb-0000:00:14.0-2/input0
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:413C:3016.0001/input/input7
U: Uniq=
H: Handlers=mouse0 event5
B: EV=17
B: KEY=31f0000 0 0 0 0
B: REL=1943
B: MSC=10

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="Fujitsu FUJ02E3"
P: Phys=FUJ02E3/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/FUJ02E3:00/input/input8
U: Uniq=
H: Handlers=rfkill kbd event6
B: EV=13
B: KEY=40000 0 0 0 0 181000000000c00 300000 0 0
B: MSC=10

I: Bus=0003 Vendor=10f1 Product=1a58 Version=0703
N: Name="FJ Camera: FJ Camera"
P: Phys=usb-0000:00:14.0-5/button
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input14
U: Uniq=
H: Handlers=kbd event7
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel HDMI HDMI/DP,pcm=3"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input9
U: Uniq=
H: Handlers=event8
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel HDMI HDMI/DP,pcm=7"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input10
U: Uniq=
H: Handlers=event9
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel HDMI HDMI/DP,pcm=8"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input11
U: Uniq=
H: Handlers=event10
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel HDMI HDMI/DP,pcm=9"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input12
U: Uniq=
H: Handlers=event11
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel HDMI HDMI/DP,pcm=10"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input13
U: Uniq=
H: Handlers=event12
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Mic"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input15
U: Uniq=
H: Handlers=event13
B: EV=21
B: SW=10

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Headphone"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input16
U: Uniq=
H: Handlers=event14
B: EV=21
B: SW=4

1 Like

Hi and welcome to the forum.

First. Have you gone to Zorin>Settings>Devices>Mouse & Touchpad
Check your basic touchpad settings are correct there.
There is also a "Test your Settings" tool top right of that screen.

Also in your Software Updater. Check source is set "Main server". Then check for Additional Drivers.

1 Like

Thanks and yes I have tried the basic settings where I do not have any touchpad options. I have downloaded an app called tweaks and in this one I can see touchpad options but no matter what I do the touchpad does not react. I have also changed to main servers and checked for additional drivers without any luck. I also have Windows 10 on the same machine and here it works without problems. The two OS are both installed with Zorin as the primary and I can switch between them in the boot menu.

Try either of these (I know they’re not the same model as yours but worth a shot):


First one did the trick!! :+1: thank you very much. I have spent days trying to solve this on my own and then I should have just started here :wink:

This line fixed it:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.notimeout i8042.nomux"

Thanks again :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.