Touchpad too sensitive

Yeah, for touchpad users, the cursor is extremely susceptible to moving with the slightest move of the finger, even when lifting off the touchpad. Windows had a setting where you could change that to make the touchpad less sensitive to small changes of finger position, not sure if there's one for Linux.

1 Like

Dont you have a button to disable touchpad ? My laptop has one and i never used the touchpad.

1 Like

Touchpad sensitivity on Linux should be handled by the synaptics drivers:
Adjust the speed of the mouse and touchpad.

Thank you for that!

I started a terminal, then typed:
xinput list

It showed the touchpad as an Alps GlidePoint, device number 14.

I then typed:
xinput --watch-props 14

... to show all the configurable attributes of the touchpad.

~$ xinput --watch-props 14
Device 'AlpsPS/2 ALPS GlidePoint':
	Device Enabled (164):	1
	Coordinate Transformation Matrix (166):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (298):	1
	libinput Tapping Enabled Default (299):	0
	libinput Tapping Drag Enabled (300):	1
	libinput Tapping Drag Enabled Default (301):	1
	libinput Tapping Drag Lock Enabled (302):	0
	libinput Tapping Drag Lock Enabled Default (303):	0
	libinput Tapping Button Mapping Enabled (304):	1, 0
	libinput Tapping Button Mapping Default (305):	1, 0
	libinput Natural Scrolling Enabled (306):	0
	libinput Natural Scrolling Enabled Default (307):	0
	libinput Disable While Typing Enabled (308):	0
	libinput Disable While Typing Enabled Default (309):	1
	libinput Scroll Methods Available (310):	1, 1, 0
	libinput Scroll Method Enabled (311):	0, 0, 0
	libinput Scroll Method Enabled Default (312):	1, 0, 0
	libinput Middle Emulation Enabled (313):	1
	libinput Middle Emulation Enabled Default (314):	1
	libinput Accel Speed (315):	0.161765
	libinput Accel Speed Default (316):	0.000000
	libinput Left Handed Enabled (317):	0
	libinput Left Handed Enabled Default (318):	0
	libinput Send Events Modes Available (283):	1, 1
	libinput Send Events Mode Enabled (284):	0, 0
	libinput Send Events Mode Enabled Default (285):	0, 0
	libinput Drag Lock Buttons (319):	<no items>
	libinput Horizontal Scroll Enabled (320):	1

Tapping Drag is something I don't want, so:

xinput --set-prop 14 300 0

And I want Natural Scrolling enabled, so:

xinput --set-prop 14 306 1

But I don't see any settings to adjust the sensitivity of the touchpad, so I have to press harder to get my finger to register on the touchpad. That's really the problem... I can even hover my finger just above the touchpad and get the mouse to move. It's just too sensitive.

Ah... I understand the issue, now.
Let me look at the .conf file and see if I can find anything.

Ensure that synaptics is installed:

sudo apt install xserver-xorg-input-synpatics

I believe the path should be /usr/share/X11/xorg.conf.d/70-synaptics.conf
Open that file in a Root Elevated Text Editor or in terminal with nano.
See this section:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection
Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

You want to add a couple more options here in the space above EndSection.

"Option" "FingerLow" "20"
"Option" "FingerHigh" "20"

Be sure to Save The File. Then reboot and test.
This next part may get tedious... I do not know the proper values you need for those... 20 may suit. Or maybe they should be 5 instead. I have no idea... I do not have a touchpad so I cannot test this.
But you may need to fiddle with both of those values a bit to find the sweet spot.

2 Likes

Thank you. I've edited /usr/share/X11/xorg.conf.d/70-synaptics.conf in root gedit, saved it, and I'll reboot now, then experiment with the values.

For those wondering how to start gedit as root:
Start Terminal
Type sudo gedit

Then you have the permissions to save the file you're editing.

1 Like

Keep the thread posted, please. As I said, I am not using a touchpad, so I cannot test, change values or verify that it even works at all.
But, it may at least be a path toward a solution.

Whoah, that's immediately a wholly different experience. After reboot, the mouse speed was way too high (although I only had it halfway up in Settings > Mouse & Touchpad > Touchpad Speed), so I slowed it down, then attempted to drag a window edge and catch the tiny scroll bars that have been the bane of every Linux user since time immemorial. Both worked well.

No more "lift the finger from the touchpad and the cursor jumps 20 pixels". I could actually go a bit higher with those settings. I'll try 30.

[EDIT]
Yeah, 30 is good. I'll use that. It's almost identical to the behavior in Windows.
[/EDIT]

2 Likes

I went ahead and split this out since it was a specific question with a specific solution - It may make this easier to find and use by other members searching the same issue.

1 Like

Just a quick note I use 16.2 Pro and Cinnamon DE .... there is some custom setting on it for anyone in the future needing to slow down their touchpad ..... go to System Settings/ Hardware /Mouse and Touchpad/Touchpad .... see the photo below ..... this may only work using the Cinnamon DE on Zorin

1 Like