Touchscreen and pen worked on installation...not the next day

Yesterday, I installed Zorin 17 Core on a Thinkpad x200t tablet (circa 2010). The touchscreen worked with touch and pen. The Wacom pen worked as well, tested with Xournal++ and Libre Office Draw.

Today, neither the touchscreen nor the pen is working.

Any ideas would be most appreciated.

Can you test clearing your /tmp and /var/log?
This may be caused by the touch software logging each event as a log and running out of space to continue.

Having read some recent posts, I understand that Zorin 17 now defaults to Wayland ... which does not support touch screens, etc.

" 5.2 Wayland/Weston

Wayland does not currently have a known method to lock touching to a specific display in any environment other than sway (or wlroots-based supported compositors). There are tools such as weston-touch-calibrator, but Gnome Wayland uses Xwayland leaving the calibrator unable to locate any touchscreen.

Wayland/Xwayland also masks the xinput list and funnels them down to generic xwayland devices such as "xwayland-pointer","xwayland-relative-pointer","xwayland-touch-pointer", etc. The Wayland method of "Xinput" is "Libinput", but does not have all the same functionality. The current known method to use touchscreens in a multi-head setup is to force Gnome or KDE to use X11. libinput currently assumes the touchscreen(s) covers all available monitors.

See Sway#Touch display mapping for settings in sway."

[Source: Touchscreen - ArchWiki]

More information on wlroots here:

That is unfortunate. Touchscreens are not that niche at this point.

What bothers me is that it did work when I did the upgrade...flawlessly. It was brilliant and I was excited to use it. Then the next day nothing. At times, the pointer will change to a finger, but then it will not register anything and the system sort of goes non-responsive for a bit.

I upgraded an ASUS T100 tablet to Zorin 16.3. 17 inverted the screen, I guess another Wayland issue. Touch works on that albeit slowly, but then it is not the zippiest of devices at best.

Nothing there to clear.
On Ubuntu forums I have found some instructions for editing xorg.conf for the x200t tablet, but Zorin 17 does not seem to be using an xorg.conf file (found xorg.conf.d). Those instructions are fairly old though...Ubuntu 8.10.
The most annoying bit is that upon installation, everything worked perfectly. Powered down, turned it on the next day, and nada.

Reinstalled Zorin 17 Core today.

On first boot after installation, everything works. Settings has section for Wacom tablet, so that is detected. Pen works, I set the button preferences and calibrate.
Start re-installing software: InkScape, GIMP, Spotify...and while doing that, am prompted to install updates which have already downloaded. I do so, and am prompted to restart; select the restart later option and continue installing applications. Create a file with InkScape using the pen and save it to Documents.

After the restart, the touchscreen is not working. This is obvious since I cannot tap my username to log in. Open settings to find their is no Wacom tablet settings listed. Pen and touch are not working. Clearly the problem is with the updates to Zorin that I installed. The bigger issue is that at some point, these updates have to be installed, and at that point, apparently, I lose the Wacom tablet.

The device runs well as a regular laptop, but my intention is to use it as a tablet so for the time being I will try a different flavor of Linux or take it back to Windows 10. Too bad.

1 Like

You can use

cat /var/log/apt/history.log

to isolate what packages were installed/changed when you ran the upgrades. With this done, you can paste that list here that we can review it to try to help.
The first thing would look at is the kernel.

You can test whether the later kernel is affecting touchscreen by booting > Grub menu > Advanced Options for Zorin and booting up from the Previous kernel on the list (most users need to drop down two lines as each entry for a kernel includes one option for Recovery and you do not need Recovery at this time)

I will have to re-install Zorin. I blew it away to give Mint a try. It looked promising, but had the same issue in the end...after shutting down for the evening and firing it up in the morning, touch was gone and while it still offered settings for the Wacom tablet, it would not detect the pen.

In both cases, after the installation, when performing the first boot from the hard-drive, everything is detected and works. It is the second boot where it all falls apart. The pen works with a much newer, though not new, ThinkPad Yoga, so I am guessing that Lenovo has stuck with the same or very similar technology, which makes me wonder why I am having this trouble

When you mention the Grub menu, are you saying to boot from the USB again and select Advanced Options from that menu?

I am going to give Debian a chance, and if that has the same issue, then I will go back to Zorin, as I much preferred the interface to that of Mint.

When you do normal HDD boot and see grub menu, select the "Advanced Options for Zorin" item. (Not USB boot)

Therein lies the problem. When I do a normal HDD boot in Zorin, I do not see the Grub menu.

I installed Debian last night, and per usual, everything worked fine. I shut down the system and fired it up this afternoon. It defaults to the Grub menu so I selected Advanced options and hit the down arrow twice which took me to:

Debian GNU/Linux, with Linux 6.1.0-17-amd64
Debian GNU/Linux, with Linux 6.1.0-17-amd64 (recovery)
Debian GNU/Linux, with Linux 6.1.0-15-amd64
Debian GNU/Linux, with Linux 6.1.0-15-amd64 (recovery)

...and everything still worked.

I then repeated the process, instead selecting the first option (6.1.0-17), and, again, everything worked as it should. So, at least with Debian, I have a tablet. The problem is that I do not like the Debian interface at all.

I will try putting Zorin back on and editing the grub file so that it is not hidden and I have a few seconds to make a selection. If that works, I may be in business.

Of course, it could be something in Gnome...

By the way, I like your avatar. I would put Kilroy on all sorts of things that I had to sign for my kids...casts, tests, whatever.

1 Like

So, I re-installed Zorin, and went to the etc/default grub. Changed grub_timeout_style to menu and grub_timeout to 10.

Powered down. Restarted. I lost the touch interface, and did not see the grub menu.

Then, edited etc/grub.d/30_os-prober.
Set quick_boot="0".
Powered down. Restarted. No touch interface, no grub menu

Then edited usr/share/grub/default/grub.
Changed timeout style to menu and timeout to 10 here.
Powered down. Restarted. No change. No touchscreen. No grub menu.

So what is the secret to getting the grub menu to display? I am new to Linux, my hardcore Unix days were long ago.

I know Zorin supports the touch and pen features because they work until I shut the machine down. Same problem with Mint. Debian worked fine, but I am not too keen on the interface. Perhaps I would be better off using Debian and switching seeing what is involved in changing the desktop, as I would at least have a working tablet.

Have you tested on Zorin OS Lite?

Would that be Debian 12?

I am mystified why the Grub Menu is refusing to show. Another Zorin OS 17 user recently posted a very similar situation.

Yes, it was Debian 12.

Zorin Lite is still 16.3 as far as I know. I am running it on an Asus T100 tablet because Zorin 17 inverted the screen. Screen rotation worked, but the screen was upside down when in the normal position attached to the keyboard.

I am new to Linux, so this has been a bit frustrating. I end up on Ubuntu sites a lot as that is the basis of many of the other distros.

So, I compared 70-wacom.conf and 40-libinput.conf from Debian 12.4 and Zorin 17 and they are identical. Why Zorin (and Mint) will recognize the touch screen and pen on installation from USB, but not when launched from HDD is baffling to me

At this point, I will probably re-install Debian and work on making the interface something I can live with. It is more important to me that I can actually use the computer as a tablet.

Too bad. I would probably have upgraded to Pro, but this is sort of a show stopper for me. I have several touch screen, pen enabled computers that I would eventually like to switch over.

Yes, I mean... you need the system to work correctly.

Debian is the base for Ubuntu. Ubuntu is the base for both Mint and Zorin OS.
With this clue narrowing things down, it looks like something occurs at the Ubuntu development that affects Distros that use it as a base. Because of this, it seems likely to not be desktop dependent, since Mint does not use the Gnome Desktop. It uses Cinnamon and XFCE.

If this is what you go with, feel free to continue to use this forum for interface customization feedback. That is something that several of us do quite a bit, so we may be able to help you to set things up to your liking. Since Zorin OS Software is free open source, you can even install the Zorin Themes.

I would prefer to see a solution to this issue. Since you are affected, others must be as well. And not just Zorin OS users.
That it initially works tells us that the included drivers and configurations also work, but that something added in interrupts that later. It's a clue, but doesn't nail it down.

Thanks for the explanation.

The problem with Debian is that the interface is sort of like Windows 8 or perhaps iOS...just screens of icons that one had to scroll through...not the examples I would choose to emulate, but whatever. It also installed older versions of almost every app I would want to use. It was on a newer version of the Linux core though.

I will stay on these forums, since I have at least one computer that is running Zorin 17, and unless I move the little Asus to a different distro just for consistency. I like the Zorin interface as it is something my family could use with little discomfort, though for the most part they would just be in the browser.

I might try installing Ubuntu, just to see if that causes the same issue.