Trackpad buttons error

So basically when I use the left button on the trackpad, most of the time it detects it as if I were pressing the right button. Any solution to this?

It may be a setting:

Already did it, still the same. They act like they're the same button, if I put primary button on left, they both act like right buttons, and vice versa. In fact, when I turn on the PC it starts working well, but a few minutes later it starts doing that

What is the exact make and model machine?

I'm sorry, what you mean with make and model machine? Like the PC?

Yes, is it an HP, Dell, MSI? What Model of Manufacturer is it?

The manufacturer is EXO. The model is Smart XS3


Yes, that one

Have you tried installing this driver:

sudo apt install xserver-xorg-input-synaptics

and restarting the notebook to test?

I know this is a bit too late (I really haven't been using this PC since then), but the trackpad has been working worse since installing that driver, sometimes it starts working completely wrong, not just the buttons, but the touchpad as well. What can I do?

If it is working worse, you can remove that driver and return to using libinput:

sudo apt remove xserver-xorg-input-synaptics

Some users report that removing inputattach and mousetweaks resolves the issue, according to the link above.
You can try:

sudo apt remove mousetweaks inputattach

Or all of the above with one command:

sudo apt remove mousetweaks inputattach xserver-xorg-input-synaptics

Reboot and test...

I've been trying it for a few days, still working wrong. Curiously, when it starts working wrong, I press the Power button on the keyboard to block the computer, and then it starts working properly again. It's just annoying to do this all the time it starts malfunctioning, but it's better than nothing

See if the solution with 3 votes on editing GRUB config helps:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.