Trouble booting zorin os 17 from USB on windows 11

Laptop is surface laptop go, any other specs I am willing to provide when asked. I have attempted flashing a usb drive with the zorin core 17 iso using both balena and rufus (in iso and dd modes) but despite a seemingly successful flash, booting fails. I am attempting to set up a dual boot with win11 and have set aside about 35 gb of free space on my hard dism for zorin.

The interesting thing is that on my first attempt it worked flawlessly and inwas taken to the “install or try” page, and instead of installing i went through the try option and later shut down directly from the zorin menu.
After that, i have retried booting feom that usb, reflashed that usb in a bunch of ways as mentioned before, and also attempted doing the same with a different usb drive and all of them lead to the same issue: the laptop boots up and freezes on the surface logo screen indefinitely, so what I’ve been doing is force shutting down using the power button, removing the usb, then turning on again to boot straight into windows.
I have attempted disabling secure boot as well as moving usb storage to the top of the boot order in my uefi settings, neither of which have worked.

Please help, as no other existing topic has given me anything.
Willing to provide extra screenshots and info as necessary. Thanks.

See if this guide helps as Zorin 17 is a fork of Ubuntu 22.04:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.