Troubleshooting yt-dl

Any time I here Hawaiian Music all I can think of is Don Ho singing "Tiny Bubbles" .... I would have posted it here but I still can't get anything to download from youtube with out creating an account with them .... and I have tried all the various download programs recommended here on Zorin .... bummer .... :rofl:

Frog, but you can.. have you tried this;

1 Like

OK I used this command to install .... ```
sudo wget https://github.com/yt-dlp/yt-dlp/releases/latest/download/yt-dlp -O /usr/local/bin/yt-dlp
sudo chmod a+rx /usr/local/bin/yt-dlp

Terminal results ..... haven't tried it yet ... not sure just what it is supposed to do but we'll see .... thanks

No idea what all this means .... :grinning:


mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo wget https://github.com/yt-dlp/yt-dlp/releases/latest/download/yt-dlp -O /usr/local/bin/yt-dlp
[sudo] password for mike:                                      
--2022-04-14 06:17:21--  https://github.com/yt-dlp/yt-dlp/releases/latest/download/yt-dlp
Resolving github.com (github.com)... 52.69.186.44
Connecting to github.com (github.com)|52.69.186.44|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://github.com/yt-dlp/yt-dlp/releases/download/2022.04.08/yt-dlp [following]
--2022-04-14 06:17:22--  https://github.com/yt-dlp/yt-dlp/releases/download/2022.04.08/yt-dlp
Reusing existing connection to github.com:443.
HTTP request sent, awaiting response... 302 Found
Location: https://objects.githubusercontent.com/github-production-release-asset-2e65be/307260205/5635289d-75fb-4f7d-9741-a5edc91ea1da?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20220413%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20220413T221723Z&X-Amz-Expires=300&X-Amz-Signature=1637b6e037418efcbe52a3284833f6c221e3d8369aebb47b31ee7eb94ed14b30&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=307260205&response-content-disposition=attachment%3B%20filename%3Dyt-dlp&response-content-type=application%2Foctet-stream [following]
--2022-04-14 06:17:23--  https://objects.githubusercontent.com/github-production-release-asset-2e65be/307260205/5635289d-75fb-4f7d-9741-a5edc91ea1da?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20220413%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20220413T221723Z&X-Amz-Expires=300&X-Amz-Signature=1637b6e037418efcbe52a3284833f6c221e3d8369aebb47b31ee7eb94ed14b30&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=307260205&response-content-disposition=attachment%3B%20filename%3Dyt-dlp&response-content-type=application%2Foctet-stream
Resolving objects.githubusercontent.com (objects.githubusercontent.com)... 185.199.111.133, 185.199.110.133, 185.199.109.133, ...
Connecting to objects.githubusercontent.com (objects.githubusercontent.com)|185.199.111.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2452364 (2.3M) [application/octet-stream]
Saving to: ‘/usr/local/bin/yt-dlp’

/usr/local/bin/yt-dlp 100%[========================>]   2.34M  1.65MB/s    in 1.4s    

2022-04-14 06:17:26 (1.65 MB/s) - ‘/usr/local/bin/yt-dlp’ saved [2452364/2452364]

mike@mike-ROG-Strix-G731GT-G731GT:~$

Oh ok, if you installed it then just use the command to fire it up. It will then download the url you provide to the pwdirectory. For example;

yt-dlp https://www.youtube.com/watch?v=30BKvLCEdkQ

you can add all kinda optional short commands to it like

yt-dlp -p ~/Videos https://www.youtube.com/watch?v=30BKvLCEdkQ 

this to download the file to the videos directory. Of course there are more optional commands possible and the list is very long. This all you can find in the downloaded ytdlp folder.

1 Like

Great .... I'll work on it some today ..... again thanks ... :+1:

Hummmm .... tried the 2 examples you gave but it said I didn't have permission .....

The denied permission is because off execute permission of that yt-dlp file in folder /usr/local/bon/yt-dlp. Well you performed the > sudo chmod a+rx /usr/local/bin/yt-dlp so there should be no problem. You could check if you have execute permission by using ls -l /usr/local/bin/yt-dlp. Mine look like this:

-rwxr-xr-x 1 root root 2415129 mrt 8 21:24 /usr/local/bin/yt-dlp

1 Like

You are missing the "x" the execute rights for that file.
Try again sudo chmod +x /usr/local/bin/yt-dlp .. and check again.

1 Like

OK that looks a bit better .....

First off thanks to Aravisian for moving this thread .... and secondly here is the results of my terminal using your first link ....

OK now let me see if I have this right ..... I go to a youtube video I want to download copy the youtube link .... I copy this into my terminal ..... yt-dlp - YouTube ..... placing the link ID where the XXXX are like this ...... [OpondfqNkrk] this is the video I chose ........ and this is the results ....... YouTube

This is your example .....

And here is the one I had ......... YouTube .... it didn't work .....

What am I missing ....

Here is what I got when I clicked on my link ......

This video is available as shown here .....

I haven't followed the latest on this, but the old version yt-dl was deprecated because YouTube was facing copyright lawsuits, though it wasn't their content. Check the repository README and ensure you have the full link (though there have been several forks of the original project, even had those repositories removed by github because of YouTube [going after github for supporting movie pirates]). It's relaxed some, but i don't know if YouTube is actively blocking the new versions as they discover them.

1 Like

I was wondering about that as I know youtube (google) has clamped down on everyone as to downloading any of their material without a user account .... with a user account you can download from youtube with a download manager which is what I can do on Win as I have a google account there .... I just wanted to find a way to down load some stuff without having to open a google account here on Zorin ....

Funny how these tech giants can copy info from you but go to great lengths to keep you from copying info from them including prosecution ..... but I guess they look at it like we GIVE them our info ... they don't really steal it ....

I have zero issues just using 4k software. I wonder if your issue is due to Regional Servers...

1 Like

I'm using a VPN to a well know country in SE Asia .... like I said I tried 4k but when I copied the share link to it and pasted it came back as

I get the same thing no matter what downloader I am using ....

1 Like

It may also be the VPN...

1 Like