Try or Install Zorin OS doesn't work, only safe graphics works

I have an HP Stream 14" Laptop, Intel Celeron N3060 Processor, 4GB RAM and I decided I wanted to get Zorin Lite. I downloaded Zorin OS 15.3 Lite on my pc and plugged in a new 16gb DataStick PRO Usb 2.0 and flashed the Zorin Lite file into the USB. Everything seemed to work well, I put the USB into my laptop (while it was shutdown), started my laptop and kept pressing f11, chose usb and it started zorin. Then 4 options showed up:

~ Try or Install Zorin OS
~ Try or Install Zorin OS (safe graphics)
~ Check installation medium for defects
~ Power Off

The first option brought a grey screen with efi: EFI_MEMMAP is not enabled.

Second option worked but ill get to it after.

Third option did the same as the first option.

Forth option shut down the laptop.

Back to the second option, when you select it, the same error comes on: "efi: EFI_MEMMAP is not enabled" but if you wait a couple seconds, it brings you to the main home screen of zorin os.

If you look to the left side of the screen. you see a shortcut named "Install Zorin OS 15.3", I double pressed that and it started the installation process. At the end of the installation, an error code came up saying "the 'grub-efi-amd64-signed' package failed to install zorin os". I honestly dont know what to do. I looked at other peoples questions which were similar but nothing could help me.


  1. Only safe graphics will load.

  2. Download won't work in the end.

  3. Please help

In your BIOS / UEFI settings of the notebook, are you set to Legacy or to EFI?

It was legacy but I switched to EFI

I did find a setting known boot repair and it gave me this url with a full report, would this help?

Did it fail in Legacy, so you switched to EFI?

If using EFI, you must first set up an EFI partition. Have you done that step, yet?

The report you pasted states: isolinux.bin missing or corrupt
This often points to the USB stick or port. Have you tried using a different USB drive, Port?
If so, you may need to go into BIOS settings and change USB Flash Drive Emulation Type to Hard Disk.

sounds good, ill try changing usb flash drive emulation type to hard disk

Also, what graphics card is this machine using?

it should be: RTS5229 PCI Express Card Reader,

also, I couldn't seem to find where to change the usb flash drive emulation type

Can you please post the terminal output of

inxi -F

In the dump you provided it says your zorin lite is the 32 bit installer. I know 32 bit can run on a 64 bit processor, but why not use the 64 bit installer since it's supported.

It also relayed that there was no efi partition, grub never installed. When you went through the installation and made the partitions, did you choose the device (sda) or did you choose the efi partition (sda1)? Was the partition marked bootable (which makes it the boot partition)? The drive still has an mbr, so a partition wasn't deleted (possibly windows System partition). Mbr and efi don't play well together. Is this a dual boot?

Sorry more questions than solutions.

1 Like

System: Host: zorin Kernel: 5.4.0-45-generic i686 bits: 32
Desktop: Xfce 4.14.2 Distro: Zorin OS 15.3
Machine: Device: laptop System: HP product: HP Stream Laptop 14-ax0XX v: Type1ProductConfigId serial: N/A
Mobo: HP model: 82BD v: 11.20 serial: N/A
UEFI: Insyde v: F.45 date: 12/04/2017
Battery BAT0: charge: 13.7 Wh 45.7% condition: 30.1/30.1 Wh (100%)
CPU: Dual core Intel Celeron N3060 (-MCP-) cache: 1024 KB
clock speeds: max: 2480 MHz 1: 2480 MHz 2: 1251 MHz
Graphics: Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
Display Server: x11 (X.Org 1.20.8 )
drivers: fbdev (unloaded: modesetting,vesa)
Resolution: 1366x768@76.00hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0, 128 bits)
version: 3.3 Mesa 20.0.8
Audio: Card Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Def. Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k5.4.0-45-generic
Network: Card: Intel Wireless 7265 driver: iwlwifi
IF: wlo1 state: up mac: 10:f0:05:f5:fb:9f
Drives: HDD Total Size: NA (-)
ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
ID-2: USB /dev/sda model: USB_DISK_2.0 size: 15.5GB
Partition: ID-1: / size: 1.9G used: 416M (22%) fs: overlay dev: N/A
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 59.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 190 Uptime: 1:46 Memory: 1460.7/3841.3MB
Client: Shell (bash) inxi: 2.3.56

So I chose the 32bit instead of the 64 beacause I thought it would run more smoothly. When I was doing the installation, it didn't really ask me for a device. I did erase choose an option during an installation that said: "delete disk and install zorin" if thats what your asking

It does ask, it's right before the gparted closes and the installation finishes. You have to read it carefully or you miss it. For some reason it sometimes defaults to the device instead of the partition. I'm referring to the something else installation, it's the only one I'll use because i seperate my home partition from root (as i was told this is better for backup and reinstalls...a fact...ty aravisian). This allows installations to be quicker and saves my customizations without having to touch a backup most of the time.

so during the installation, a couple of options showed up:

~ erase your disk and install zorin,
~ encrypt...
~ use LMV...
~ Something else

I pressed something else and found what you were talking about. screenshot below:

I want to download zorin on the last one with 15519mb in space. so I right clicked it, and pressed add, switched the "Use As" to "Ext4 journaling file system" and chose the mount point to "/". I also switched the "device for boot loader" to the usb. everything was perfefct and it should have worked, but it said: "No EFI System Partition was found. This system will likely not be able to boot successfully, and the installation process may fail. Please go back and add an EFI System Partition, or continue at your own risk.

im clueless at this point

The boot partition has to be on one of the drives, or you would need to have the usb to boot your system to Zorin. You should have a 500mb partition formatted as fat32 for efi marked as bootable. You should have root (/) partition formatted to Ext4 for root. If you want, you can set an Ext4 partition for home (/home). In the picture below I have unallocated space where my efi partition was (I went back to booting using the windows partition for my dual boot). Then it's the root, home and an ntfs data partition to share between the two OS's.

The root partition should not be marked as bootable, only the efi partition.

That is a small partition...

Hard drive is only 32 gig? Is it emmc? Most drives, even nvme are at least 128gb. Haven't seen anything that small since the 90s except emmc and sd. The 15gb usb is actually a half decent older pen drive (usb-disk) suitable for live images.