"try or install zorin os" freezes

I'm new to Linux and it's probably the third day trying to install zorin os, but every time i boot to the pendrive and select the "try or install zorin OS" option, my PC completely freezes, and I can't find a solution

Can someone please help me? I really want to try this OS

Are you using Intel, AMD or Nvidia Graphics?

1 Like

I'm with Intel integrated graphics

Hmmmm... this is already a stumper... The only reason I know of that causes this (Aside from a Corrupted .iso) would be Nvidia or AMD graphics struggling to initialize the trial version -given the generic non-installed drivers.
Would you be willing to double check your machine and see if you also have a dedicated GPU?

1 Like

No,i don't have a dedicated GPU (sadly)

Accessing your EFI / BIOS Settings, can you check if you are using AHCI or RAID?
Is windows currently Installed? If so, which version?
How much RAM do you have?
Have you tried a different USB port?
What size USB drive did you place Zorin OS .iso on?
And... What etcher did you use to burn it?

And... did you check the SHA256 checksum of the downloaded iso?

1 Like

I have windows 7 installed, 2gb of ram, the USB drive is 8gb, and I'm using BalenaEtcher

I'm going to try an different USB port, didn't test it yet

Also, try a different etcher.
2gigs of RAM - that is a bit low. Shouldn't be a problem with the Try Zorin, but I would aim for Zorin OS Lite...
Windows 7, I believe has Fast Startup or Fast Boot in Control Panel > power
That can be turned off for your trials.

1 Like

Yeah, i checked it and it's fine

1 Like

Going to try Rufus

Unetbootin is another good alternative to Balena etcher.
(Balena has a poor reputation for wrecking USB sticks according to several forum mentions, even though it is the suggested installation tool by the devs.)

1 Like

Aha! I can prove the installer does indeed freeze.
I did a major mistake last night while tinkering with my system half asleep and was unfortunately forced to reinstall Zorin on my main machine.

Went through packages check then Install or Try Zorin window popped up - it froze the entire system.
After waiting couple of mins and clicking on Install every now and again it did in fact work - but!
After selecting the erase disk setting and other usual things, it went to installing the system itself and it froze.
After 20 mins of waiting (went to have a shower) I had to force shut down laptop, did the install from the scratch again and worked flawlessly.
Went with Nvidia drivers option both times.

Not an issue for me just confirming it does indeed tend to happen.

1 Like

I needed to edit your post in order to align it to the Forum Guidelines. Normally, I would have sent you a Private Message notifying you of the changes - but you have your profile locked. So a public message will have to do.
Please remember that the forum is intended to be a Family Friendly environment where all ages, parents and kids alike, can use the resources of the forum comfortably.

What is the most frustrating of such things is wondering what the cause was - and why it magically fixed itself.
I have no trust in things that fix themselves...
Automotive Check Engine Lights...
Borg...

1 Like

Yeah no worries Aravisian, understood.

I had deleted files in Nautilus via Root privilege and was unable to restore them as kept on getting two different error messages.
First the directory missing and other access denied - while being on a root. :rofl:
It was totally my bad, so I do not blame the OS itself but my stupidity of messing around with system past 11pm while being awake since 5am and long day at work. Lol.
I had my data backed up on a USB drive so was just a matter of reinstalling the system via the other USB stick.

But yeah, with launcher I have no idea what could have been causing it - just wanted to chop in my two cents that the bug does in fact exist.

1 Like

I am going to annotate this for the ZorinGroup to review - since it is a relevant issue other users may face.

I wish I had a nickle for every time I went exploring in root and made a mess of things. When I first started using Linux I created some amazing disasters.
Such things are quite rare now...

1 Like