Trying to create a 2nd login account. Getting error

You will find very few distributions that are as easy to use as ZorinOS, but then again this is can be very subjective. Which is why why there are so many options to choose from in the first place (and what makes Linux great!).
I personally install ZorinOS because I've found it to be much easier and familiar to those who come from Windows and are not necessarily very tech-savvy.

ZorinOS, Linux Mint and Pop_OS! are all based off of Ubuntu, which is quite stable. They all introduce some changes based on how they think the user experience should be like. For example Mint rejects the Gnome desktop environment and created their own, called Cinammon. Pop_OS! has recently started to shift away from Gnome as well and are in the process of coming up with their own desktop environment called Cosmic. ZorinOS customizes Gnome heavily to make it look and feel closer to what Windows does.

In either case, these changes tend to be mostly on the surface. For example the cryptic error messages we were talking about earlier probably come from the underlying Ubuntu code itself.

Either way, I think the issues with overheating are probably due to some bad installation or program that is misbehaving. I would worry about identifying this first before moving away to another distribution where you may or may not have this and other issues.
You can start by removing those programs you installed, and install them back again one by one to see which of them, if any, start causing trouble again. It's a bit of a meme, but the classic turn it off and back on again solves a lot of issues...

If you were to move to another distributions, I would suggest Linux Mint or Pop_OS! as your firsts alternatives. Fedora and OpenSuse are also great alternatives that I find slightly more advanced but quite user friendly.

1 Like

About this issue you linked in particular... I honestly have no idea, not all programs report the error messages to the same log files and they require a little more digging.

But hardware failure as described in the issue can in turn cause a lot of other errors, for example a program may be trying to read/write to a file that is no longer reachable and thus enter an infinite loop, causing increasing memory usage, which in turn causes overheating, etc.
This is true regardless of the OS being used... hardware failures are bad.

1 Like

@zenzen , thank you for all the advice & info, I've made sure to write all the important stuff down. :slight_smile: :nerd_face:

1 Like

With all those messages being written to logs, your log files must be occupying excessive space on your drive.
Once you have found the culprit and stopped excess log messages, you may wish to tidy up your log files.
There is some commands and guidance here that will help you with that:

1 Like

MX Linux is my advice.


-rw-r----- 1 root adm 491M Mar 19 15:32 /var/log/syslog
That's a big log! Wow!

1 Like

@zabadabadoo , thanks!

MX Linux is also very good, comes with a lot of installed programs made by the maintainers and community to work out common tasks. I think I would prefer still Linux Mint however, but definitely another solid choice.

Once I saw this get into the GBs.... To this day I still don't know what caused it, I ultimately had to reinstall everything from scratch

1 Like

@zenzen , @Nicolaco_08 ,I'm confused, where is this figure coming from? when was it 1st mentioned?

-rw-r----- 1 root adm 491M Mar 19 15:32 /var/log/syslog

I assume this is on @Nicolaco_08's computer?

1 Like

Then again, Windows would also tell you that the program executed an illegal operation or give some other vague and generic problem code that you could spend weeks trying to sort out.
On Linux, most often, it does inform what went wrong and even gives a suggestion on how to fix it.
How often do we see the terminal provide "Try ap --fix-missing" or so on.
And our society has been conditioned to be so untrusting, users will still hop onto this forum to ask what to do.

You are just beginning your journey into Linux.
What journey starts off smoothly? What journey begins with you having all the knowledge and experience you need to start that journey perfectly?
You get knowledge and experience from the journey.
How you are feeling is normal. When I switched from Windows to Linux, it took a sledge hammer to my skull to drive home the point that Linux is not Windows.
And as I had problems with Zorin OS, I tried setting out on Distro Hop - based on my wants and standards, seeking that Best Distro For Me. I tried many, found a few favorites... But finally settled on the distro that checked the most boxes: Zorin OS Lite.

It was then I realized that it is not the distro. They are mostly very similar.
It was me.
Many of my problems were User Created. I pushed forward without taking the time to learn.


@Aravisian , thanks for the comment. Based on my experience windows would be much clearer & tell the user that # aint allowed. The fact that Zorin/Ubuntu couldnt even tell me that it didnt like a # in my password, is a serious issue, the principle of it i mean.
Instead of it communicating clearly with me, it spit out a bunch of complex (& if I might say) b*llshit code. I have a serious issue with this type of behavior, complicating things where it need not be. Simplicity is very important to me. I want to make clear that I'm not going to abandon linux, & I'm not trying to whine for the sake of whining, but linux, or Zorin to be precise, is poorly designed in this respect. Regardless, Zorin still might be the best OS for me, idk. I need that windows compatibility/hybrid features as much as possible.

Terry Davis, Creator of Temple OS said: “An idiot admires complexity, a genius admires simplicity, a physicist tries to make it simple. For an idiot the more complicated anything is the more he will admire it, if you make something so clusterf*cked he can't understand it he's gonna think you're a god cause you made it so complicated nobody can understand it. That's how they write journals in Academics, they try to make it so complicated people think you're a genius”

Davis also hated Linus T, & linux, but yet he chose to use ubuntu, rather than microsoft or MacOS.

A perfectly valid observation. If there is a simple issue with password creation, it should be straight-forward to code it to relay why the password was rejected.
I think, though, that while it is a valid complaint, it pales in comparison for where Windows OS utterly fails. I think that my observation of most Windows Errors being obfuscated is just as valid.

The source of this particular error is Debian not Ubuntu or Zorin OS. Why not submit a bug report on it as a suggestion?

I am a subscriber to many journals. I can agree that sometimes, people use "big words" in order to "sound smart." However, much of the case in academic writing, precision is required. I cannot stress this enough:
Precision is required.
Think of how often it is and how easy it is in daily communication to suffer misunderstandings in communication. Language is by and large, very imprecise.
By using Set well defined terms in academic writing, this is lightly alleviated, allowing less wiggle-room for error in communication.


On this particular case, I think there's a strong case in favor of not giving away precise details about the cause of the error. Information about user credentials, such as minimum number of characters, set of characters allowed/disallowed, etc. can be extremely useful for an attacker.

I get this happened in the context of a personal computer and not a server, and it would be a valid proposal to relax this restrictions a bit in this scenario, but it's important to understand where the error comes from (at least that's my interpretation of it).

By the way I just tried to add a new user from the terminal using the "2nd" username which is not allowed, and the error message shown were the same three lines we identified in the logs as the explanation to the issue. And it comes with an easy fix by using additional flags.
I'm just mentioning this because I think it gives another perspective to the issue of "being clear" about what's happening. It's just that Linux is much more terminal-oriented like that.

For reference in case you need to create users again in the future you can do so with this command:



@Aravisian , Thanks for explaining.

2ndly, I am a reader, researcher & subscriber of many journals myself, I agree with you about logical need for complex words to be precise. Although, I still think that journals need to work on making things simpler, it is an often forgotten wisdom, especially in academics. Also, journal "abstracts" & "summaries" sometimes are poorly put together, making it hard to understand.

1 Like

@zenzen , thank you explaining. How would you differentiate creating a user who is an administrator, compared to one who isnt?

In short, it's a user that has the ability to run programs as sudo. The default way to do this is by adding the user in question to a group conveniently named sudo. If you type groups in the terminal, you will get a list of the groups your user belongs to. Among them you should see sudo which is what "makes you an admin".

In a previous post I mentioned you could add a user using this command: sudo adduser --gid 4 <username>. This adds a new user AND specifies the numeric representation of a group it should automatically be added to. In this case I see that I made a mistake as the sudo group's id is actually 27 (not sure what happened there :sweat_smile: ).

1 Like

'#' is allowed so long as it is part of the user name, such as mine!

I found the file where this sort of rules are specified is /etc/adduser.conf. In there there's a line specifying the regular expression that validates the username:

# check user and group names also against this regular expression.

This specifies that the username must start with a lowercase letter, followed by any number of characters including lowercase letters, numbers and underscores.

From what I've read online about this, the reason to prevent numbers at the beginning is because some commands like chown may read the arguments incorrectly. I'm not sure though why uppercase letters are not allowed.


Also, another weird annoyance/flaw? of zorin, when u try to printscreen/screenshot, u absolutely cant screenshot a pull down menu? this seems to me to be stupid?
And i know u can use the delayed screenshot app.
But windows 7 would screenshot everything.

1 Like