Trying to install libudev-dev

Hello everyone, I am trying to get LogiOps on my Zorin OS 16 Core machine but I'm getting stuck at trying to install libudev-dev which is causing an error shown below:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libudev-dev : Depends: libudev1 (= 245.4-4ubuntu3.11) but 245.4-4ubuntu3.13 is to be installed
E: Unable to correct problems, you have held broken packages.

Any help would be appreciated. Thanks!

Let's hope this can fix it.

sudo apt-get update --fix-missing

sudo apt-get install -f

sudo apt-get update

sudo apt-get clean

sudo apt-get autoremove

sudo apt-get update

sudo apt-get upgrade

After that try again please.

1 Like

Beware the X-Y problem.

You may be installing the wrong package, then getting caught up in trying to fix it, losing sight of your initial goal.

sudo apt --fix-broken install


sudo apt install cmake libevdev-dev libudev-dev libconfig++-dev git

git clone GitHub - PixlOne/logiops: An unofficial userspace driver for HID++ Logitech devices

Follow the installations instructions in the ReadMe file.

I just tried it and still have the same issue. Any other ideas?

Hi Aravisian, I tried what you suggested but I still have the same issue. Any other ideas?

Worth a shot trying on Synaptic and using Edit -> Fix Broken Packages after you get a dependency error.

Hi carmar, just to make sure I understand, you'd like me to do the following

  1. Go to the terminal and run:
    sudo apt install cmake libevdev-dev libudev-dev libconfig++-dev git

  2. Then, when I get the dependency error, I run Synaptic and click on Edit -> Fix Broken Packages.

Is that correct?

Or you could also do step 1 on Synaptic and just install the packages from there. Basically, skip the terminal.

I tried with Synaptic but got the same error

Your repository is up to date (I checked against my wife's Z16 machine) and my Z15 machine shows version 237-3ubuntu10.52 for libudev.

There's a version issue, as you can read here: Can't install libudev-dev on Ubuntu 16.04 - Ask Ubuntu
I know that link's for 16.04 but I'm underscoring the issue - the "fix" suggested there can be used to get the version you need but it's at your own risk.
I looked for libudev_245.4-4ubuntu3.11 but I couldn't find it.

Sorry, in sum, no good news from my end.

I just checked this in apt... You must see this:

sudo apt install libudev1=245.4-4ubuntu3.11

looks good... But it wants to remove:

alsa-base apturl blueman bluez brltty brltty-x11 cinnamon cinnamon-core
cinnamon-session colord gnome-control-center gnome-disk-utility
gnome-software gvfs gvfs-backends gvfs-daemons gvfs-fuse hplip
initramfs-tools initramfs-tools-core libsane libu2f-udev libudev1:i386
lightdm media-player-info nautilus nemo nemo-fileroller network-manager
network-manager-gnome network-manager-openvpn network-manager-openvpn-gnome
network-manager-pptp network-manager-pptp-gnome plymouth plymouth-label
plymouth-theme-spinner plymouth-theme-ubuntu-text plymouth-theme-zorin-logo
plymouth-theme-zorin-text pulseaudio-module-bluetooth rhythmbox
rhythmbox-plugin-alternative-toolbar rhythmbox-plugins sane-utils
simple-scan software-properties-gtk steam:i386 ubuntu-drivers-common
ubuntu-release-upgrader-gtk udev udisks2 update-manager update-notifier
upower xfce4-power-manager xfce4-power-manager-plugins xiccd xorg
xserver-xorg xserver-xorg-core xserver-xorg-input-all
xserver-xorg-input-libinput xserver-xorg-input-synaptics
xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-amdgpu
xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-intel
xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon
xserver-xorg-video-vesa xserver-xorg-video-vmware
zorin-additional-drivers-checker zorin-os-lite-core zorin-os-lite-desktop

The following packages will be DOWNGRADED:

I think this is not worth the risk.
This is also a BUG on part of the packager... The dependency conflict is created by the package which has that specific dependency listed.
Reporting this to the developer may be more useful.

1 Like

Just wanted to post this as it contains alot of libdev1 packages.

I also found this, not sure if any of these might or will work for you.

There are .deb packages there, but like @Aravisian you really want to risk all of this ?

I recommend against. That procedure is very similar to the one I used to make it possible to install kernels upward of 5.12 on Zorin OS. However, I made sure to check everything else, first.

Apt installs through DPKG.
Deb Packages install through DPKG.
DPKG is what will determine whether to remove ^ the list posted above... So installing the .deb package will not help in this case - you will either run into dependency problem or run into software conflict. And a GUI installer may not tell you what it is about to remove... It's one of many why I prefer the terminal.


Thanks for clearing that up.

Agreed. Probably not worth the risk. Thanks

Agreed. Not worth the risk. Thanks for your help

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.