Trying to install Nvidia drivers, but made it worse

Here is some info on my system

$ sudo lshw -C video
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: GK107M [GeForce GT 750M Mac Edition]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:c0000000-c0ffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:2000(size=128) memory:c1000000-c107ffff
  *-graphics
       product: EFI VGA
       physical id: 1
       logical name: /dev/fb0
       capabilities: fb
       configuration: depth=32 resolution=2880,1800
$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I'm coming from Fedora, and there I got my drivers working by intalling the nvidia-470xx drivers.


I tried installing the Nvidia drivers via Software updater > Additional drivers, but got this error

After reboot, my drivers looked like this:

But I got an error when trying to install something

I looked around on this forum and tried a few commands:

$ sudo apt install nvidia-drive-390
$ sudo apt install -f
$ sudo apt --fix-broken install
$ sudo apt update && sudo apt full-upgrade
$ sudo apt install nvidia-driver-390

$ sudo add-apt-repository ppa:kelebek333/nvidia-legacy
$ sudo apt update
$ sudo apt install nvidia-graphics-drivers-390

Then my drivers look like this:

Now the graphics problems are worse, and I can't revert to the nouveau drivers :sweat_smile:

Any ideas on how to install the proper driver?

This is a fresh installation of Zorin os 17, so having to reinstall the system ins't a problem if that would be necessary.

First disable the third party source driver, you can do this in software center burger menu.
Next;

sudo apt remove --purge *nvidia*
sudo reboot

Should give you NV driver back.

2 Likes

I've got the Nouveau drivers back, thanks!

Any suggestion of how to get the proper Nvidia drivers working?

I could now select this driver and everything works smoothly!

Not sure what made this driver suddenly pop up?

@Storm was correct- you needed to remove and purge the previous 390 drivers before installing them from the Kelebek repo after.

1 Like