Trying to install Zorin OS 16, installation always fails with "Unable to install Grub in /dev/sda"

Hello everyone,

I'm currently trying to install Zorin OS 16 on my external SSD however every time I try to do so the installation always ends in the same error message, no matter whether I choose to install the bootloader on my main, internal SSD together with the Windows Bootloader or on the external SSD.

I am creating a 512MB EFI partition, a 2GB boot partition, a / partition and a swap partition. The installation always ends the same way. I already tried to use Grub repair, but considering the installation never actually finishes but crashes, even after booting into Zorin OS I have low resolution and neither Ethernet nor Wifi work so it's unusable. Any advice here? I've literally tried everything I could find so far. I'd also like to add that I have been distro hopping for a while to check out different distros. The last one I had installed was Manjaro and it was working flawlessly, booting straight into the Manjaro Bootloader where I could choose it or Windows.

Thanks in advance.

EDIT: Automatic installation of Zorin OS alongside Windows fails the same way. I'm out of ideas.

Can you relay what the error message says?
Are you using Nvidia or AMD graphics card?

1 Like

What do you mean by a 2GB boot partition? The EFI partition is the boot partition. Then you need root, swap is created as part of root so it isn't necessary to create a swap partition. You may want to use a seperate partition for home, but that's a matter of preference.

I take it your using the something else method of installation, since alongside windows and erase the drive doesn't give you a way to specify partitions that i know.

In the something else method, after choosing the root and home locations it will ask you where to install grub, you must either choose the windows efi partition (100MB) or the efi partition you created (500MB and ensure it is marked as bootable). What it seems is happening is that the device (/dev/sda) is being chosen instead of the partition (/dev/sda1) and that will not allow the installation of grub.

If you choose a different drive other than windows, or a different partition other than the windows efi partition, you will have to hit f12 and change the boot order to boot into Zorin.

1 Like

I am indeed. I have an Nvidia card, GeForce RTX 2060. I had already previously installed Zorin PS 15 without any issues but that was the first Linux I installed on this machine, afterwards I started distro hopping a bit from Zorin to Solus to KDE Neon and finally Manjaro.

I have already tried the alongside option and it did try to install on the external SSD but it ended in the same error.

Afterwards I tried Something Else again, creating just an EFI (512 MB) and a / partition. I have tried installing from a fresh computer start as well as by entering this blue Windows menu and selecting the boot medium. I tried just a / partition. I tried selecting the Windows Bootloader for the installation in the drop down at the bottom, tried choosing my main SSD and also my external one. It always ends the same.

I have never seen a context menu asking where to install Grub. So when using Something Else, I should not create an EFI partition, but instead a /boot one and choose the Bootloader to be put along with the Windows one in the drop down selection?

In Something else method of installation, when you get to the gparted screen, it asks first for root installation location. You choose the partition, and set the mount as /. Then it will ask for home installation, which you don't have to change. The third part asks where to install can be missed since the only thing that really changes is the text under the partition list (horizontal gui of partitions). It may seem that there isn't a change, that it just didn't accept the click on ok. Read it carefully and choose the existing efi partition (windows may have named it EFI). There will be no mount point. if you right click the partition and hit properties, boot should be checked. No other partition should have boot checked, unless your other efi partition is where you install grub.

You do not need to create a boot partition when dual booting with windows.

I just loaded my installation media and the very first thing it wanted to do was install the boot loader (grub) and automatically choose the device.

You have to choose the efi partition:

So should I set it up like on the 1st or the 2nd screenshot? Meaning, should I just the main drive or the partition p2 which is the efi partition? For now, I have only created a root ( / ) partition on my external SSD.

That 500mb needs to be fat32 in order to hold grub. If you want the option to boot windows or zorin at the grub menu use the windows efi, nvme01p2... otherwise you'll have to access the bios boot order to boot zorin. So it's a personal choice. So you don't have issues trying to change it later I'd choose to add it to the windows efi partition.

1 Like

So I did that just now, created a / partition on the SSD and in the drop down I chose the Windows bootloader partition and the installation still ended in the same error. I'm again at a loss.

1 Like

At this point, it appears that the installation has completed except for the installation of Grub.
So, you won't be able to boot. I would recommend running Grub Repair at this point. It may not fully solve the mystery... But it should get you up and running.

So, after running Boot Repair, I got this text file. I am ok with Linux, but nowhere near even intermediate knowledge level. is there anything of use in here that could explain why I'm having this issue?

I will try rebooting into Zorin OS now and see if I can get things up and running. Last time I tried boot repair and entered Zorin, it was half-baked. No resolution change possible, no wifi, no ethernet - basically nothing I could do to finish the set-up. Thanks for all the help and patience, by the way.

1 Like

Yep. Right off the bat:

Windows is hibernated, refused to mount.

If Windows is in Hibernate, it locks the drive.
Moving below, we see:

grub-install: error: cannot copy /usr/lib/shim/shimx64.efi.signed' to /boot/efi/EFI/Boot/bootx64.efi': No space left on device.
Exit code: 1
df /dev/nvme0n1p2
mv winEFI cancelled (nvme0n1p2 full)

"No space left on device" shows the same - unable to access due to Windows Lock.

Could not mount read-write, trying read-only
An error occurred during the repair.
Locked-NVram detected.

Can you remove the Windows Hibernate, ensure Secure Boot is disabled and also double check in the Windows Control Panel, Powers settings that "Fast startup is not enabled?
IF it was me... I would try a full reinstallation of Zorin OS once the Windows Locks are removed rather than troubleshoot an existing interrupted one...

Also, I see nvme drive- please ensure in your EFI settings that RAID is enabled, not AHCI...

No idea I even had something like Windows Hibernate enabled, don't even know what that is. I'll go into the BIOS and check for Secure Boot. The odd thing is, though, that I did manage to install Zorin OS 15 without any issues.

After booting into Zorin, it informed me that I have only 31kb on EFI remaining, also under About it showed my main SSD with 512 GB instead of my 256 external one. I have changed the mode from AHCI to RAID now but couldn't find any secure boot option, so I'm going into Windows now and will disable fast boot if it's activated. Then I'll try again.

EDIT: Fast startup was already deactivated.

It is odd. Many Linux users install Zorin (15 or 16) on eMMC or nVME with no trouble. Others do have trouble. It's fickle.
In fact, for a long time, the general consensus was that Linux OS's simply cannot be installed on eMMC and would never be compatible. Progress has been made... But the fight's not over yet.

Hopefully this page can be more helpful than I am:

That may also relate to the trouble... Can you use the windows partition manager to increase the size of your EFI partition? 512 megs, maybe?

I've just tried, I can't manipulate the EFI partition in any way, which means I'll have to find another way to do this. Shouldn't it be possible for me to install the bootloader completely onto the SSD, in a way so that my computer won't be affected but I would be able to choose to boot onto the SSD if it's attached by pressing F11 during bootup?

EDIT: It just came to my mind that there might be remnants of the old Linux distributions blocking and clogging up the space on the EFI partition. I will try going into Zorin and try to remove those folders if they're there.

1 Like

How to clear out old EFI entries from Windows:

Or from a Linux distro:

1 Like

Thanks for the link :slight_smile: Unfortunately for me there were no Linux entries anymore so I'm back to finding another solution.

I have recently tried just creating a Boot partition and a root / partition on the SSD and tried to install grub into that boot partition (512 MB) but that also didn't work. It almost seems as if GRUB cannot be installed at all.

This is very frustrating.

Please see here:

and here I created a list so I could just keep track of all the similar issues.

I am going to try bumping this one up to the ZorinGroup to see if they can examine the packages.

1 Like

Regailia776, this bug may be affecting you:

1 Like